EMac - not reading Cd's

Discussion in 'General Mac Discussion' started by EMKAL, Oct 16, 2004.

  1. EMKAL macrumors newbie

    Oct 16, 2004
    Can anyone help? - This is my first post to this forum. Have checked the archives (maybe I missed it - but I am desperate to fix this issue).

    I have the CDRW drive on my EMac. I have had this unit for almost 2 years with no problems.

    Although I hate to admidt it I use it in Classic Mode rather than System X but that is here nor there as the problem is the same whether I run in Classic, OSX or run Classic from OSX

    It started with - itunes all of a sudden not reading some of my music CD's with the error coming up "This computer can not read this disc - -Eject or Initialize.

    Just before this was happening I had run a CD burning session to org my "millions" of photos about 15 Photo CD's. All the CD's were checked and readable once burned before I started to unload some of the baggage on the system.

    Now a few months later the CD drive seems to select only a few CD's to read - and many are now coming up Can not read - Eject or Initialize.

    I thought after 2 years re-installing the system 9 might be a good idea - but guess what - the CD Drive will not read any of my system discs either.

    I am a publisher of two Wedding Planners and I am right in the middle of production - yikes!!!! I really need some help :confused:

    Look forward to hearing from anyone who may have the same problem or a soft fix that I could do myself - no techy but pretty smart

  2. Gee macrumors 65816

    Feb 27, 2004
    London, UK
    Non-techy type solution....Have you tried one of those head cleaning CDs you can buy with the little brush on - might just be a case of dust on the lens or something. eMacs are tray-loading, right? Never actually tried a headcleaner in one but I don't expect it can do any harm....

Share This Page