eMac trauma

Discussion in 'PowerPC Macs' started by Ollie C, Jul 21, 2010.

  1. Ollie C macrumors newbie

    Joined:
    Jul 21, 2010
    #1
    Hey all, I'm having a spot of bother with an eMac I wanted to nurse back to health.

    It was originally 1.25ghz with bad capacitors. I let a friend help me replace the caps which led to a butchered board which I'd say is very broken now. (Incidentally I did another one myself which works fine. :p)

    Anywho, I bought a board I found on ebay going cheap, it's a CPU step up, the 1.42ghz board. The board is unused and came in the original Apple packaging and with ethernet ID sticker etc. I couldn't find anything beforehand to indicate that it wouldn't work and it's rare to find just a board on ebay now so I went for it. Physically, the boards are identical, it went in the emac without a problem.

    I lovingly assembled it all, fairly sure I've done it properly.. stuck to the Apple service source throughout, both ways. I plug it in and press the power button and the CRT makes the usual noise and sometimes the fan will whir up for a moment then it goes completely dead. It never gets far enough for an image to appear on the display.

    It seems like a power issue to me, I have tried turning it on with the super drive disconnected but it did the same. I've also tried resetting the PMU to no luck.

    Anyone got any ideas to help? :)

    Thanksss,
    Ollie.
     
  2. 76ShovelHead macrumors 6502a

    76ShovelHead

    Joined:
    May 30, 2010
    Location:
    Florida
    #2
    I'd suggest checking the ram, as the board as you say is identical, and i cant see why it wouldn't work-but perhaps when you and your friend demolished the last board, you accidently fried your ram. :confused:
     
  3. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #3
    That doesn't sound like a symptom of bad RAM to me--normally that'd either panic or fail the startup test and give the corresponding bad memory beeps (I think...).

    Two easy things to try before trying to debug a power problem: Make sure the motherboard battery is good--with a board that old it could well be dead, and a dead PRAM battery can result in exactly that symptom. If you have a voltmeter you can test it, or put in the old one from your old Motherboard (if you didn't already) or just buy a fresh one to test.

    Don't forget the PMU reset that's part of the replacement battery procedure, as a crashed PMU (which could easily have happened with what you've done to the thing) can have exactly the symptoms you're seeing:

    http://support.apple.com/kb/ht3005

    If that doesn't help, try removing the battery, unplugging it, pushing the power button, letting it sit for maybe 10-30 minutes, re-adding the battery, push the PMU button, plug it in, and hope for the best. I've had that revive G4-era computers that were acting up with power issues.
     

Share This Page