eMac won't boot, even from original Software Install DVD

Discussion in 'PowerPC Macs' started by jrippon, Sep 6, 2012.

  1. jrippon macrumors newbie

    Feb 29, 2012
    I have an eMac (G4, 1 GHz; ATI Radeon 7500 Video card) which will no longer boot, even from the original Software Install and Restore DVD.

    I ran the Apple Hardware Test from the original CD, and it found no problems.

    My father (it is his eMac) then took the computer to an apparently authorised Apple service provider, who told him that the hard disc needed replacing and that it would be better to buy a new iMac.

    I was not convinced, so removed the hard disc and tried booting from the Software Install DVD. The result was the same. The Apple logo and spinning wheel appear, but after a few seconds a jumbled strip appears across the screen and the computer freezes. Picture is attached. It looks to me as though something is mistakenly being loaded into the Video RAM instead of into the normal RAM (or perhaps into the wrong part of the Video RAM).

    What I have done to date:
    - Removed hard disc
    - Replaced two suspect capacitors on the down-converter board. All others on both boards seemed OK.
    - Replaced RAM with a new 256GB stick.
    - Replaced PRAM battery
    - Reset NVRAM and PRAM both using appropriate startup key sequences and directly using the open firmware reset (reset-nvram, set-defaults, reset-all)
    - Run Apple Hardware Test - no problems found (see attached picture)

    Before I call it a day and consign the machine to the scrap heap, does anyone have any suggestions as to what else I could try, either to help diagnose the problem or fix it?

    Thanks in advance for any advice.

    Attached photos:
    1) Hardware Profile, from Apple Hardware Test
    2) Hardware Tests result screen (extended test)
    3) Frozen screen
    4) Close-up of frozen screen

    Attached Files:

  2. havokalien macrumors 6502a


    Apr 27, 2006
    Kelso, Wa

    I am no expert but I have seen and been told the screen issue you have is due to a throwback transformer issue. Capacitors failing shorten the life in it. Basically the same issue as in the original compact macs. Considering how old they are its up to you if it's worth replacing. Maybe you could get a whole board off someone. Also the length of time to boot from disc after reset of pram can take up to 45 minutes someone with an eMac posted within the last week. My eMac took 35 minutes for me to wipe it and install.

    I'm sure there are other more precise answers, but I have seen these as most common.

  3. Intell macrumors P6


    Jan 24, 2010
    Do you have a mini-VGA to VGA adapter to test it out with an external display? That could be the video card. eMacs do not have a throwback transformer, they have flyback ones. A failing flyback transformer doesn't do this. A failing one dims the display until there is no longer any light output from it.
  4. jrippon thread starter macrumors newbie

    Feb 29, 2012
    Thanks to both of you for your replies.

    No, I don't have an adapter or an external display unfortunately, so can't try that idea. However the fact that it completely freezes up suggests that it is more than just the display.

    I have tried a 'verbose mode' boot (cmd - V), and I did notice the same garbled strip appear across the screen and then disappear up into the blackness as the screen scrolled down and eventually froze. If I could get it to output the results to a file somehow then I imagine that would help to locate the problem, but I can't of course as the machine doesn't boot up. Perhaps I'll try taking a video of the screen and see if I can make out what is happening before it freezes.
  5. Intell macrumors P6


    Jan 24, 2010
    If it freezes up completely, it's like the capacitors. Even good looking ones can be bad on the inside and that model eMac is known to have capacitor problems.
  6. jrippon thread starter macrumors newbie

    Feb 29, 2012
    Yes, I found one that was clearly in need of replacement, and another that looked a bit dodgy so I replaced those (both on the small down-converter board), but as you say, it's difficult to tell just by looking. I had a similar problem with an HP printer last year, and perhaps by chance managed to pick the right capacitors and that fixed the problem.

    Other than just going through and changing all the capacitors one by one, is there any possible way of working out logically which is likely to be at fault, given that they all look OK on the outside?

Share This Page