emacs23 under snow leopard "cannot open termcap database file"

Discussion in 'macOS' started by 1ric2, Aug 16, 2010.

  1. 1ric2 macrumors newbie

    Joined:
    Aug 16, 2010
    #1
    Hi,

    this is my first post here.

    I recently installed Snow Leopard (10.6.4) on my MacBook. I just installed macport and I was trying to install emacs (23.2) with it.

    the installation proceeds without errors, but when I try to launch the program I get the following error message:

    "emacs: Cannot open termcap database file".

    Can anyone help me?

    thanks

    ric
     
  2. Mal macrumors 603

    Mal

    Joined:
    Jan 6, 2002
    Location:
    Orlando
    #2
    Not sure about that error, but emacs is already installed on Mac's by default. Dunno which version, but you might just try what's already there.

    jW
     
  3. 1ric2 thread starter macrumors newbie

    Joined:
    Aug 16, 2010
    #3
    Thank you for your reply Mal!

    Yes there is already a version of emacs that runs in the terminal, but I would like to have the one that runs on an external window. It used to work before upgrading to Snow Leopard. I was running Tiger and I could successfully install it with fink and run it.

    Now, after upgrading fink according to the official website, I cannot install it anymore. So I tried macport, which actually installs it without errors, but then I get this strange (to me ;) ) error message....
     
  4. 1ric2 thread starter macrumors newbie

    Joined:
    Aug 16, 2010

Share This Page