Email Arrival Slow Compared with iPad, iPhone

Discussion in 'MacBook Pro' started by jweakley918, Apr 8, 2014.

  1. jweakley918 macrumors newbie

    Joined:
    Jan 25, 2014
    #1
    I have a wireless connection through Cox Communication. I recently acquired a new MacBook Pro, which automatically created the connection to Cox. Unfortunately, incoming email to the MacBook is much, much slower than it is to my iPhone or iPad—in those cases incoming email is instantaneous. Is there a setting I need to change to correct this? Cox told me to contact Apple, as there is no setting Cox has to increase email delivery.
     
  2. simon48 macrumors 65816

    simon48

    Joined:
    Sep 1, 2010
    #2
    How are you receiving email on your MBP? Apple Mail?
     
  3. jweakley918 thread starter macrumors newbie

    Joined:
    Jan 25, 2014
    #3
    Yes.

    ----------

    I set up my mobile devices using POP settings, but the MBP automatically set up the connection as an iMAP (I think that is the correct designation.)
     
  4. simon48 macrumors 65816

    simon48

    Joined:
    Sep 1, 2010
    #4
    Under Mail > Preferences > General you can change the "check for new messages" option. I would try "automatically" and "every minute" and see if one helps.

    Whether you should use POP or IMAP totally depends on what Cox supports, check with them. Use IMAP if you can.
     

Share This Page