Email Badge not clearing

Discussion in 'Mac Apps and Mac App Store' started by Hls811, Feb 5, 2008.

  1. Hls811 macrumors 6502a

    Hls811

    Joined:
    Apr 19, 2004
    Location:
    New Jersey
    #1
    For some reason whenever I open mail the badge is showing a '4' on the dock icon. I don't have any new mail - I went through each folder to make sure nothing was hidden - and if I go online to check my .mac account that way it shows up as '0' new messages.

    Is there a way to reset the dock badge?

    This just started happening about 2 days ago.

    I went through each of my mailboxes/folders and did a rebuild but that didn't help..
     
  2. hodgjy macrumors 6502

    Joined:
    Apr 15, 2005
    #2
    Try this:

    Right click the name of the mailbox and select "synchronize" from the menu. That's worked for me in the past.
     
  3. Hls811 thread starter macrumors 6502a

    Hls811

    Joined:
    Apr 19, 2004
    Location:
    New Jersey
    #3
    Nope :(

    Unfortunately that didn't work either. I even went to far as to remove my .Mac account from Mail and re-configure it! Even when there wasn't ANY mail account associated it did it! (If I sign into my .Mac account via the web its not showing any new messages) - its something w/ the app - not the mail account.
     
  4. Hls811 thread starter macrumors 6502a

    Hls811

    Joined:
    Apr 19, 2004
    Location:
    New Jersey
    #4
    I fixed it!

    I created a Smart Mailbox to show all unread messages - and go figure, there were 4 unread messages! I'm not sure why they didn't show in my inbox, but regardless - it allowed me to read them and the badge is now accurate again!
     
  5. onelegtwoshoes macrumors newbie

    Joined:
    Jul 6, 2007
    #5
    Perfect!!

    This worked perfect for me, I wonder why they didn't show in the inbox. Does mail have an archive option?
     

Share This Page