Email bug with 2.2?

Discussion in 'iPod touch' started by 4DThinker, Nov 23, 2008.

  1. 4DThinker macrumors 68020

    Joined:
    Mar 15, 2008
    #1
    With 2.2 on my 1st gen Touch I can no longer delete any email, no matter which account it's from. I get the pop-up message:

    "Unable to Move Message
    The message could not be moved to
    the mailbox Trash."

    Anyone else have this problem? Better yet, anyon know of a fix?

    4D
     
  2. PeteB macrumors 6502a

    PeteB

    Joined:
    Jan 14, 2008
    #2
    I'm getting the same on my 2gen Touch.

    I see it on my SMTP mail account, but I'm able to delete emails from my Exchange account.

    This functionality worked on FW 2.1.1
     
  3. cakbar macrumors regular

    Joined:
    Apr 30, 2008
    #3
    Wirelessly posted (Mozilla/5.0 (iPod; U; CPU iPhone OS 2_2 like Mac OS X; en-us) AppleWebKit/525.18.1 (KHTML, like Gecko) Version/3.1.1 Mobile/5G77 Safari/525.20)

    I had the same problem with AOL mail via my touch, since 2.2. I fixed it by changing the destination of "Deleted Mail" to the "Saved" folder on the AOL server. It seems to me that if there is no Trash folder on the email service, then there is nowhere to send the trash to, unless you redirect it to another folder.
     
  4. Blunk macrumors member

    Joined:
    Jan 15, 2008
  5. 4DThinker thread starter macrumors 68020

    Joined:
    Mar 15, 2008
    #5
    Anyone else with 2.2 email delete problems? It's not fixing itself. Every time I get new email the available space on my touch gets smaller, and since I can't delete it my 8gb Touch will eventually run out of space for anything else.
     
  6. iConnor macrumors member

    Joined:
    Sep 24, 2008
  7. zero.fx macrumors member

    Joined:
    Nov 19, 2008
    Location:
    London
    #7
    i dont seem to have any problems regarding deleting emails, but one problem i do have is that my ipod touch 2g doesnt seem to push email unless i open the mail app. I have the settings to push and fetch new data every 15min but still doesnt seem to push. it only works when i open mail app manually then i will see the emails. is this even normal?
     
  8. hobbbz macrumors 6502a

    hobbbz

    Joined:
    Mar 8, 2005
    #8
    Just putting this out so people know whats up.

    I had the same issue with a personal IMAP account.
    Found a post that said to make sure under Settings>Advanced>Deleted items that it was pointing to "On my iPhone Trash" mine was but i changed it temporarily and then put it back to "On my iPhone Trash" it worked after that.
     
  9. 4DThinker thread starter macrumors 68020

    Joined:
    Mar 15, 2008
    #9
    Thanks, hobbbz. I finally got mine to work although to be more specific:
    Settings
    Mail, Contacts, Calendars
    (pick one of your accounts)
    Advanced
    Deleted Mailbox (change to something other than what is set, for example from Trash (on my iphone) to Trash (INBOX) or Deleted Messages.
     
  10. patsfan83 macrumors regular

    Joined:
    Apr 6, 2008
    #10
    These advanced options are not available on the exchange preferences. Any ideas?
     

Share This Page