Email is supposed to check every 15 mins, but it doesn't!

Discussion in 'iPhone' started by joejoejoe, Jan 27, 2008.

  1. joejoejoe macrumors 65816

    Sep 13, 2006
    Hey guys,

    I'm on my third iPhone, and every one that I've owned has had this same problem.

    I set the mail app to check for new email every 15 minutes, but sometimes it doesn't do it for hours and hours, and I need to manually open the app and it starts checking again.

    It's really annoying. Is anyone else having this problem?

    If its happening to a lot of people maybe this can get enough attention for Apple to fix it in the next software update.

    p.s. i use gmail imap and my university's imap as well
  2. mtfield macrumors 6502

    Jan 9, 2008
    You're not the only one. I have a .mac account and sometimes it too will go for a very long time without checking... but as soon as i manually open, it receives email fine.
  3. chadrob30 macrumors 6502


    Nov 13, 2007
    In front of my Mac.
  4. knoxtown macrumors 6502

    Nov 19, 2007
    I agree.... although my gmail seems to work better then my .mac in terms of autocheck. It's annoying, but its not that big a deal to me.
  5. sr5878 macrumors 6502a

    Jun 5, 2007
  6. runplaysleeprun macrumors 6502a


    Jul 27, 2004
    Chicago, IL
    Its happened to all users as far as I know since day one (iDay). I'm surprised this problem has persisted to 1.1.3.
  7. TEG macrumors 604


    Jan 21, 2002
    Langley, Washington
    My iPhone checks my G-Mail IMAP about every 15 minutes. I do however routinely turn off the auto-check (to reduce the GSM noise on my iTrip), but after I've turned it on it checks every 15 minutes like clockwork. Perhaps cycling the auto-check resets something. I'd try it and see what happens.

  8. ThePhenom415 macrumors newbie

    Jan 24, 2008
    I think the problem with the iphone is the same one that plagues most pda email clients - if the phone does an automatic check and there has been no new email for an x number of tries, then the phone stops checking automatically until you manually check again to get it going. My experience anyway.
  9. Craigy Boy macrumors member

    Dec 27, 2006
    I find it too. I have my phone set it to check every 30 minutes, sometimes it seems to do that, other times it seems to go a whole afternoon without checking until I manually do so.
  10. nickspohn macrumors 68040


    Jun 9, 2007
    It was after a update it stopped working. It did work for a while though. I think it was 1.1.1 when it stopped.
  11. pedroistheman macrumors 6502


    Sep 10, 2007
    probably one of the main concerns of those interested in using the iPhone for business needs...why is the lowest setting 15 mins? Is apple concerned for battery usage or what? How do blackberries download mail so smoothly?
  12. ikare macrumors member

    Jan 21, 2008
    Canton, Mi.
    I have hotmail and it also does not auto-update and I too have checked the settings for every fifteen minutes, I should be able to slide the unlock button and have mail updated, kinda annoying
  13. mrtune macrumors 6502a

    Jun 23, 2007
    Mine is like that too. Most times it checks fine. Occasionally it won't check all day. I gotta go in and manually do it. Been like that on my phone through every update. I got mine on iDay.
  14. Illinoisemakers macrumors member

    Jan 2, 2008
    I have this problem with my yahoo account. Anyone else?
  15. joejoejoe thread starter macrumors 65816

    Sep 13, 2006
    exactly, worries about battery getting drained.

    blackberries use push tech for email while the iphone and most other smartphones use pull technology.

    with push, the email gets sent to your device the moment it is sent, and the phone never has to auto-check for email at certain intervals (i think the iPhone only does this with Yahoo accounts)

    With pull, the device checks at regular intervals through POP or IMAP to see if there's any new mail, so you'll never get emails instantly.

    I hope in the future the iPhone becomes an all push device.
  16. jeffmc macrumors 6502

    Sep 21, 2007
    all of you should reset/restore
    it's a software issue on your phone not with any of the service providers
  17. Stardotboy macrumors regular

    Jan 30, 2008
    Manchester, UK
    I'm having the same problem... it's frustrating as it works fine for about 90% of the time - but will suddenly stop checking again.
  18. ben5959 macrumors regular

    Aug 15, 2007
  19. NotoriousBOG macrumors newbie

    Jul 3, 2007
    I had the same issue, but I found it resolved when I turned Data Roaming on. (Settings > General > Network) I don't know why Auto-Check mail would be indirectly tied to data roaming, but give it a shot to see if that fixes things for you.
  20. Jsingh macrumors member

    May 8, 2007
    I'm going to try that out, I had to result to auto-check because push email was also pretty random.
  21. michaelmcfadden macrumors newbie

    Feb 11, 2008
    iphone not as quick to check for mail as BBerry

    Blackberries use either BES or BIS....a separate enterprise mail server or web mail client which automatically checks for and forwards your emails from your account to a separate Blackberry account email address unique to the invididual blackberry device. That blackberry therefore only looks like it is interacting with your email and getting it instantaneously, but youre actually paying about $25 more a month than the iphone plan to have blackberry check your email and forward copies of them to the **** address that is assigned to each blackberry device. If you choose NOT to pay the extra $25 for the blackberry mail forwarding, a blackberry will check for new emails every 15 minutes just as the iphone does.
  22. d21mike macrumors 68040


    Jul 11, 2007
    Torrance, CA
    What version is your Firmware? My Yahoo Push has been working great since either 1.1.2 or 1.1.3. It has been working so good for so long just can't remember which version fixed it.
  23. speakerwizard macrumors 68000


    Aug 8, 2006
    dont a lot of imaps not work on mobile networks due to security reasons, swear i read that somewhere
  24. Shannighan macrumors 6502a


    Jul 26, 2007
    Buffalo, NY
    i noticed this as well, though it seems to be better since 1.1.3 and IMAP though gmail. it is annoying indeed. sometimes i go though school and work without it checking! though i usually open mail manually.
  25. WarDogg macrumors newbie


    Feb 8, 2008
    Los Angeles
    This worked for me! Thanks!

Share This Page