Email not working on 3Gs

Discussion in 'iPhone' started by bobt, Jun 19, 2009.

  1. bobt macrumors regular

    Joined:
    Nov 17, 2006
    Location:
    Michigan
    #1
    I just upgraded from an original iPhone to a 3Gs. Everything has been going smooth except a couple of my email accounts are not working. I'm getting a message that my username or password is incorrect however it is setup the same as my prior iPhone.

    Other message when I try to send a message from these accounts says that there is no password even though I have entered it in on the mail setup screen for these accounts. It is acting as if there is no password entered.

    Thoughts?
     
  2. DiamondMac macrumors 68040

    DiamondMac

    Joined:
    Aug 11, 2006
    Location:
    Washington, D.C.
    #2
    MobileMe account?

    Even if not, go through the setup and make sure the settings are set up properly
     
  3. Zengrok macrumors newbie

    Joined:
    Jul 10, 2008
    #3
    I had to enter passwords for all my mail accounts before they would work. I guess just make sure you're using a correct password.
     
  4. dusters711 macrumors regular

    Joined:
    Aug 12, 2008
    #4
    Same... had to re-enter passwords because they weren't there!
     
  5. jmpage2 macrumors 68030

    jmpage2

    Joined:
    Sep 14, 2007
    #5
    It's actually documented that you will have to re-enter email passwords and re-pair BT devices after a full restore.
     
  6. ncsimmons03 macrumors member

    Joined:
    Jul 24, 2008
    #6
    I had this problem on my 3G today. My email has always worked fine now it says the passwords are incorrect even though they are still there and they haven't been changed.

    Edit: I upgraded on the 17th and it worked fine until today. Doing a restore as a new iPhone to see if that corrects the problem.
     
  7. deceptichop macrumors regular

    Joined:
    Dec 16, 2008
    #7
    same thing happened to me. But it only happened when my phone was on Edge. When it switched to 3G then it was golden!
     

Share This Page