Email Port Blocked

Discussion in 'iPhone Tips, Help and Troubleshooting' started by THISISWEIRD, Feb 15, 2009.

  1. THISISWEIRD macrumors newbie

    Joined:
    Feb 15, 2009
    #1
    So I just switched from the BB Curve to the iphone. I love it except for one small issue.

    I have three outgoing mail servers on my phone: 1)work (primary server), 2) home, and 3) ATT's network. This mimics my mail setup on my MBP.

    When I'm home and on the home network, each time I try to send an email, it takes forever. I assume this is because it first tries the work server (which is the primary and blocked by my ISP) and then tries my home network settings.

    This delay bothers me as it slows me down when on my home network. Is there a workaround for this?

    When I use my MBP at home, I just select the home server before I send the email. If I forget, it tries and tries to send until it finally asks to use the home server. I can't figure out if this is an option for the iphone.

    Thanks.
     
  2. DPA macrumors 65816

    DPA

    #2
    In Settings, tap Mail, Contacts, Calendars. Then tap the home email that you want to change the default server for. Scroll down to the SMTP settings and tap it. Reset the primary server to the one your would like to use.

    David
     
  3. THISISWEIRD thread starter macrumors newbie

    Joined:
    Feb 15, 2009
    #3
    So I need to change this every time I change locations?
     
  4. ppc750fx macrumors 65816

    Joined:
    Aug 20, 2008
    #4
    Yep. Or you could just use one server and spoof the "From" address. (That's what I do/did.)
     
  5. DPA macrumors 65816

    DPA

    #5
    No, this is the email server it is trying to send it from. If it is first trying to use your work server for you home email then this will tell it to use the home server for the home email. I assume that, unchanged, all accounts have the same default server. I hope this fixes your problem.

    David
     

Share This Page