Email problem on new iPhone 3GS!!!

Discussion in 'iPhone Tips, Help and Troubleshooting' started by chase71320, Jun 25, 2009.

  1. chase71320 macrumors newbie

    Joined:
    Dec 14, 2008
    #1
    Im on my fifth day with my new iPhone 3GS (upgraded from first-gen iPhone), and I've been experiencing some difficulty with Mail. First of all, when I upgraded the phone to 3.0, all of my four email account passwords disappeared. So I went under Settings, reentered the passwords, and all seemed well. I was able to receive and send email. Now, for some reason I can't send email! An error message pops up saying "No password entered," and I've already triple-checked under Settings to ensure that my passwords are entered. Can somebody point me in the right direction?
     
  2. BryanLyle macrumors 6502a

    BryanLyle

    Joined:
    Aug 2, 2005
    #2
    If you can receive mail but can't send mail, make sure you also have your password entered under your SMTP settings for that mail account.

    I had to set up all of my passwords as well.
     
  3. chase71320 thread starter macrumors newbie

    Joined:
    Dec 14, 2008
    #3
    Worked. Thanks friend.
     
  4. BryanLyle macrumors 6502a

    BryanLyle

    Joined:
    Aug 2, 2005
  5. Rat-Boy macrumors 65816

    Rat-Boy

    Joined:
    Jul 28, 2008
    Location:
    Georgia
    #5
    Yup, this got me too with Gmail setup.

    I had to put a send mail password in SMTP to fix it but I don't remember having to do that before.
     

Share This Page