Email Push No Longer Working on iPhone

Discussion in 'iPhone Tips, Help and Troubleshooting' started by mac77bear, Dec 23, 2009.

  1. mac77bear macrumors newbie

    Joined:
    Jan 16, 2004
    Location:
    NYC
    #1
    I live on the east coast NYC area and for the last two weeks or so my email had not been pushing. I use a mobile me account and up till two weeks ago every email showed up automatically when it was recieved. Now my iPhone has gone back to the pre push days where you have to manually check for new mail. My settings are all set for Push to work so that is not the issue. I am wondering if anyone else is experiencing this problem? Also thinking that it is an AT&T issue where they may have turned off Push due to all the network problems they have been having. What I like to call the fake 3G network, where you get full bars and 3G on the phone but get no service(internet or email). Those in NYC and SF know what I'm talking about. What a scam, I wonder how they get the phone to show full bar 3G and clearly not be on the network.
     
  2. megapopular macrumors 6502a

    Joined:
    Aug 21, 2007
    #2

    Try turning off push... Send an email or two to yourself, then power cycle the iPhone... Enable push again and send an email from a pc. Best luck!!
     
  3. scaredpoet macrumors 604

    scaredpoet

    Joined:
    Apr 6, 2007
    #3

    While it's en vogue to always blame the network, it's probably a settings issue in your phone. Worst case, if you remove and then re-add your MobileMe account, it should start pushing properly again. This happens sometimes after restoring your iPhone from backup.
     
  4. alent1234 macrumors 603

    Joined:
    Jun 19, 2009
    #4
    must be MobileMe. i have an Exchange account set up and it's working with no problems and i'm in Midtown and Queens
     

Share This Page