Email settings?

crrcoal

macrumors newbie
Original poster
Jun 20, 2012
24
0
Ever since I updated to IOS12/Mojave I have noticed an issue with email on my phone and MBP. It used to be that emails that were on my phone stayed there until I accessed mail on my MBP. Then they would leave the phone. Now the mail stays on both and if one deletes so does the other. Anyway to "fix" this?
 

niji

Contributor
Feb 9, 2003
1,826
1,717
tokyo
what Mail client are you using on yr mac? apple's Mail?

on my setup, which seems to be the same one as you prefer (the one you had before iOS12/macOS Mojave), even with updating both systems i still have this desired behavior: mail downloaded and/or read on my iPhone still is downloaded to my mac when i access Mail. and, it removes it from the server as well, which therefore removes it from iPhone.
i didn't change any setting i had in place before or after the updates.
however, the way i did/do have it set up is that on my mac i have set the Mail/Preferences/Accounts/Mailbox Behaviors to have all mailboxes be "On my Mac". and, as well, i dont leave anything in the Incoming mailbox. its all put into mailboxes (which are actually just folders in Mail) that i have created and mail is sorted into these Mailboxes directly and this act is what actually is removing the mail from the server.

the above accomplishes for me what youre looking for.
i just want to use iPhone for reading and immediate replying, and the mac for reading/composing/replying/filing/storing.
 

crrcoal

macrumors newbie
Original poster
Jun 20, 2012
24
0
Hi niji. Tried the settings and it didn't change anything. Wish I had stayed HS/ios11.
 

NoBoMac

Moderator
Staff member
Jul 1, 2014
2,849
1,181
Depends on your mail provider, but pretty sure the way it's working is correct. IMAP, which most services use these days, keeps the mail on the servers. Delete in one place, deletes everywhere.

Now, most services will keep trash around for 30 days or more, so can always refile deleted emails to Inbox or some other folder.

Only other thing I can think of is that the Mac was maybe originally setup to use POP for email fetch, which has options for "delete from server" when the mail is pulled down, and phone probably set to IMAP, which would "delete" the emails off the phone since it does not see them on the server after downloaded to Mac. Can check your mail provider support pages to see if they still offer POP, and what those settings are, and then can reconfigure the settings on the Mac mail account to use POP.

Personally, I'd keep it like it is. If you lose the Mac or have a disk failure, all your old email is lost.
 

C DM

macrumors Sandy Bridge
Oct 17, 2011
48,583
17,218
Ever since I updated to IOS12/Mojave I have noticed an issue with email on my phone and MBP. It used to be that emails that were on my phone stayed there until I accessed mail on my MBP. Then they would leave the phone. Now the mail stays on both and if one deletes so does the other. Anyway to "fix" this?
What email provider do you use and how is it configured?
 

crrcoal

macrumors newbie
Original poster
Jun 20, 2012
24
0
Welp, tried to change from imap to POP but am unable to do so. I use comcast and they still have POP however within Mojave there is no option to select it. I've deleted my account several times and each time can only create with imap.

Sigh. Once email are on my MBP, I do not want them on the comcast server anymore.
 

NoBoMac

Moderator
Staff member
Jul 1, 2014
2,849
1,181
Does the Comcast account show as an option for setting up (ie. you see in the list Google, Exchange, iCloud, Yahoo, and Comcast in the list)? If so, you need to setup Comcast for POP as an other account and manually enter all the port numbers, servers, etc manually.
 

coldwaves

macrumors 6502
May 30, 2011
331
63
Welp, tried to change from imap to POP but am unable to do so. I use comcast and they still have POP however within Mojave there is no option to select it. I've deleted my account several times and each time can only create with imap.

Sigh. Once email are on my MBP, I do not want them on the comcast server anymore.
Once the account is setup, you will not be able to change from IMAP to POP. It can only be specified during the account set up.

Once you delete the account, set it up again. When it asks you for the account password, intentionally put in a wrong password or a wrong username. Then the laptop/computer would not be able to verify your account and a window will pop up to let you manually enter the setting. There, you may be able to choose between IMAP and POP. I haven't tried this on Mojave and iOS 12 but it used to work on earlier version of iOS and macOS.

Another thing to add is the option to remove from server when you set up a POP email account. Make sure you check that option to configure it the way you want. My experience is that removing from server after certain days or after moving to trash does not always work reliably. So I have never used it extensively.
 
Last edited:
  • Like
Reactions: NoBoMac

NoBoMac

Moderator
Staff member
Jul 1, 2014
2,849
1,181
Once you delete the account, set it up again. When it asks you for the account password, intentionally put in a wrong password or a wrong username. Then the laptop/computer would not be able to verify your account and a window will pop up to let you manually enter the setting. There, you may be able to choose between IMAP and POP. I haven't tried this on Mojave and iOS 12 but it used to work on earlier version of iOS and macOS.
Just tried on a Mojave system and still works this way. And to tweek settings (eg. Ports, smtp server), Mail > Preferences > Accounts
 
  • Like
Reactions: coldwaves

crrcoal

macrumors newbie
Original poster
Jun 20, 2012
24
0
Ok got Mail set up as POP on my MBP. However once mail loaded onto my MBP, mail still sits on the comcast server. Ok got it to work. Many thanks to you guys!!! This is why Macrumors rocks! Thanks again!!
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.