Emails fetching / pushing too frequently

Discussion in 'iPhone' started by Awhendricks, Dec 17, 2014.

  1. Awhendricks, Dec 17, 2014
    Last edited: Dec 17, 2014

    Awhendricks macrumors newbie

    Joined:
    Dec 17, 2014
    #1
    My new iPhone 6 Plus has a weird email problem. I've got my Gmail and Exchange email accounts set to fetch hourly. My Gmail account however receives emails in 5-15 minutes. I don't know how well my Exchange account is fetching. I have checked and double checked my settings, but I still can't figure it out. The Gmail account was set up under the Google email choice. Any help is appreciated. Thanks.
     
  2. jozeppy26 macrumors 6502

    jozeppy26

    Joined:
    Jul 8, 2008
    Location:
    St. Louis
    #2
    Do you have "push" enabled?
     
  3. Awhendricks thread starter macrumors newbie

    Joined:
    Dec 17, 2014
    #3
    I've got push off, fetch enabled on all accounts, and it is set to hourly. I've even deleted the gmail account to start all over.
     
  4. jozeppy26 macrumors 6502

    jozeppy26

    Joined:
    Jul 8, 2008
    Location:
    St. Louis
    #4
    So you have push off for each account and overall within the "Mail, Contacts, Calendars" page in the settings app? Hmmmm, weird. Maybe you just had mail.app open recently so it's still running in the background and still fetching? I'm not too sure. Just curious, why do you have push disabled?
     
  5. Awhendricks thread starter macrumors newbie

    Joined:
    Dec 17, 2014
    #5
    I really don't need emails pushed. Just wanted to get them hourly
     
  6. punisher1-1 macrumors member

    Joined:
    Mar 28, 2010
    #6
    I have the same issue but it only happens if I leave the mail app open in the multitasking bar. If I close the app it fetches like I have it set.
     
  7. Awhendricks thread starter macrumors newbie

    Joined:
    Dec 17, 2014
    #7
    I've made sure to clear my multitasks. My wife's iPhone 6 plus also does not fetch hourly either. I've talked with Apple, and they are supposed to follow up with me tomorrow morning. I'll let everyone know what I find out. Maybe it's a software bug?
     
  8. JayLenochiniMac macrumors G5

    Joined:
    Nov 7, 2007
    Location:
    New Sanfrakota
    #8
    I take it you're constantly alerted with new emails? Just turn off alerts (none for alert style when unlocked) and/or deselect show on lock screen and notification sound and have just badges in Settings > Notifications > Mail.
     

Share This Page