Emails lost from Inbox of POP account

jlwoodard

macrumors newbie
Original poster
Oct 1, 2015
2
0
After upgrading to El Capitan, after my emails were upgraded to the new Mail version, one of my POP accounts is missing all the emails in its Inbox. Only the new emails from today are showing up in the inbox. I had a number of subfolders under the Inbox for this account, and the folders and emails within the folders seem to be intact--the problem seems to be just with missing emails in the Inbox of my POP account. One other issue is that I also noticed that one Exchange account was duplicated twice. I am wondering if it is safe to delete the duplicate IMAP accounts.

Thanks so much in advance for any assistance you can provide. I do have Time Machine running and presumably have backups of before the upgrade.

John
 

Loblolly

macrumors newbie
Oct 1, 2015
6
0
After upgrading to El Capitan, after my emails were upgraded to the new Mail version, one of my POP accounts is missing all the emails in its Inbox. Only the new emails from today are showing up in the inbox. I had a number of subfolders under the Inbox for this account, and the folders and emails within the folders seem to be intact--the problem seems to be just with missing emails in the Inbox of my POP account. One other issue is that I also noticed that one Exchange account was duplicated twice. I am wondering if it is safe to delete the duplicate IMAP accounts.

Thanks so much in advance for any assistance you can provide. I do have Time Machine running and presumably have backups of before the upgrade.

John
 

Loblolly

macrumors newbie
Oct 1, 2015
6
0
After upgrading to El Capitan, after my emails were upgraded to the new Mail version, one of my POP accounts is missing all the emails in its Inbox. Only the new emails from today are showing up in the inbox. I had a number of subfolders under the Inbox for this account, and the folders and emails within the folders seem to be intact--the problem seems to be just with missing emails in the Inbox of my POP account. One other issue is that I also noticed that one Exchange account was duplicated twice. I am wondering if it is safe to delete the duplicate IMAP accounts.

Thanks so much in advance for any assistance you can provide. I do have Time Machine running and presumably have backups of before the upgrade.

John
Solution for me: Mailbox > Rebuild
 

Whackintosh

macrumors 6502
Mar 8, 2009
434
14
Montreal, Quebec
I just upgraded my OS to El Capitan and am having the exact same problem, only Rebuild doesn't seem to be doing anything at all. :( Is there another possible course of action that I could take? I'm kind of freaking out here.
 

jlwoodard

macrumors newbie
Original poster
Oct 1, 2015
2
0
Thank you, Slieb!! It worked for me too! I had to do it a couple of times though. I think I started moving/deleting emails before it was finished rebuilding, and all of what I moved/deleted did not "take." After waiting long enough though, your suggestion worked. I also was able to move my POP account to an IMAP account, which will hopefully be better in the long run. Many thanks again!
 

neilford

macrumors member
Jun 13, 2007
82
5
los angeles
Had the same issue.
Solution for me: Mailbox > Rebuild
El Capitan

I was seeing some behavior where a pop account inbox would not display in the "Inbox", but mail was there when I went to that mailbox. I tried rebuilding pop account mailbox. Now all mail is gone. I went to Library>Mail and found in V3 an Inbox_rebuild which seems to contain missing mail. Can I reintegrate these emails back into my inbox? Thanks.

Neilford
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.