Emergency help needed. Please!

Discussion in 'macOS' started by Live Steam, Dec 18, 2008.

  1. Live Steam macrumors regular

    Joined:
    Dec 30, 2007
    #1
    Well 10.5.6 did my iMac in. I have finally been able to get into terminal throught the Tiger boot disk that it came with. The OEM Leopard disk is just an upgrade and not recognized as a boot disk.

    What can I do from this point in order to either roll back to 10.5.5 or to boot using some basic configuration. I don't know the commands to switch to the computer's root directory. The terminal reads -bash-2.05b#.

    Can I save my system or do I need to start over with installing Tiger and then updating to Leopard disk that came with my computer. There must be something that can be done to get past the blue screen.

    Also, when I tried to boot using verbose, the error message was "importer start failed for 501. invalid destination port.

    Help would be greatly appreciated as I did a partial backup before updating to 10..5.6, but I still have important files on board that would be critical if I lost them.

    Thanks in advance for your help.
     
  2. Cerebrus' Maw macrumors 6502

    Joined:
    Mar 9, 2008
    Location:
    Brisbane, Australia
    #2
    From the prompt, just try typing-

    fsck -fy


    and see what it returns
     
  3. Live Steam thread starter macrumors regular

    Joined:
    Dec 30, 2007
    #3

    I cannot get into terminal mode from booting. I can only get into terminal from the utility on the install disk. I don't know how to switch from there to to HD directory.
     
  4. JNB macrumors 604

    JNB

    Joined:
    Oct 7, 2004
    Location:
    In a Hell predominately of my own making
    #4
    From a Teminal prompt type: cd /Volumes/volumename, where volumename is the name of your Mac. If there's a space in the name, like My Mac, then enclose it with quotes, as in: cd /Volumes/"My Mac".

    Note that it's case-sensitive, so CAPS are important! From there, you can fsck, or you can actually do it withour switching, as in:

    fsck -fy /Volumes/volumename
     
  5. madog macrumors 65816

    madog

    Joined:
    Nov 25, 2004
    Location:
    Korova Milkbar
    #5
    cd /
    or
    cd .. (maybe just one .)

    ...is a way to "change directory" to the root of the system. However, I thing the fsck command requires that the drive is not mounted so I'm not sure how that works out when using the Terminal and not verbose mode (command-s during boot I believe).

    For starters, how is it that you cannot boot from the Leopard disk you have? The system can only be updated when booted via the disk, so even if it is technically an "upgrade" disk it should still provide that basic function. I know that some of the previous Tiger "upgrade" disks were bootable and also could install independently from a previous system as I used one to reinstall an OS to a new drive in the past.

    Have you tried simply running repair permissions/disk from the Disk Utility while booted to the system disk? You might not be able to run the permissions repair with an older system disk, however, the disk repair should function the same.
     
  6. Live Steam thread starter macrumors regular

    Joined:
    Dec 30, 2007
    #6
    Well thanks all for your help. After doing some reading on archive & install, I decided to take the plunge and do it. I had to install Tiger first, as this is what came with my iMac last January. The install preserved all of my data and even my apps. There are some issues in getting back my settings and configurations, but my Mac is back. I am now in the process of upgrading to Leopard from the upgrade disk that also came with my computer back in January. I'll then will run the 10.5.5 combo update. I'll have to give the 10.5.6 some more thought and time for the bugs to be fleshed out. I'm tired and going to bed, but thanks again for your comments and suggestions.
    Bill
     

Share This Page