EMERGENCY OS 10.2.8 Expert needed for login/admin/user/password problem

Discussion in 'Mac Basics and Help' started by CaineMutiny, Jan 15, 2011.

  1. CaineMutiny macrumors newbie

    Joined:
    Jan 15, 2011
    #1
    Just sold an old ibook I had lying around. Was chock full of graphics software. Rarely used. Mint cond. Wanted to clean off my user account. Made some really dumb mistakes. Now, all screwed up!

    OS 10.2.8 running.

    Originally was set up as single user/admin Lars Price short name: lp password: password

    So that the new owner (Betty Smith) could put whatever name/info she wants into the computer, I tried to change above as: Your Name short name: yn password: password

    Changed name in USER, but short name still: lp

    Went to NetInfo Manager: users > lp and changed all the lp's to yn
    STILL, the home folder name was: lp
    Could NOT change this.
    (***One more dumb thing I did in NetInfo Manager, was to go to the following property: passwd and change the never-before-seen-by-me password, which now I can't remember, nor did I write it down, to "password."

    Created NEW user as: Betty Smith. Gave Betty (the new owner) ADMIN status. [short name: bs, password: password].

    Logged off and logged on with Betty Smith account using password "password".

    WOW! Now all my apps disappeared and system is minimal.
    Went to NetInfo Manager: users > found some more lp's. Changed them to yn.

    Logged off and tried logging back on again as Lars Price
    AND NOW MY PASSWORD, which has always been "password" doesn't work!

    Logged back on as Betty, went to NetInfo Manager, and put back ALL of the yn's to their original lp. The ONLY thing I can't put back is that weird password that I changed to "password."

    Tried again to log on as Lars. My password "password" does NOT work!

    OMG, I am supposed to get this sucker in the post and ship it to the new owner YESTERDAY.

    WHAT to do????

    One more thing: At some point when I set up Betty as an admin account, the system asked me if I wanted to disable the autologin something-or-other. I don't know what I selected.
    When I go to users (remember, I'm logged in as Betty) and see BOTH accounts: Lars Price and Betty Smith, under "type", they are BOTH labeled "Admin." When I select Lars Price and click on "Set Auto Login", it asks me for the password. I put in (of course) "password" and it says that is INCORRECT.

    NOTE: I bought this second hand from a Mac Dealer (many many years ago). Ergo, I am NOT the original owner. In fact, in NetInfo Manager > afpuser_aliases, there is some guy named Mark.

    BTW, when I now look in NetInfo Manager > Groups > Admin, under users (in the bottom window) it now lists (root, lp, bs, yn).

    I do NOT have the original 10.2.8 disks. The machine is also running OS9 Classic and Virtual PC. I have the OS9 disks.

    Thanks everlasting to anyone who can help.

    Lars
     
  2. chrismacguy, Jan 15, 2011
    Last edited by a moderator: Jan 15, 2011

    chrismacguy macrumors 68000

    Joined:
    Feb 13, 2009
    Location:
    United Kingdom
    #2
    Okay, well UNIX (OS Xs base) is designed so the shortname cant be changed. Your best bet is to try and borrow a Mac OS X 10.2 disk (Booting of it and using it to reset the password is just about the easiest solution out of the mess youve created). If all the apps have disappeared, where were they stored, because under Jaguar anything in MacHD>Applications can be accessed by everybody, so they shoudnt've disappeared unless they were installed only into the user space for the Lars account.
     
  3. dmmcintyre3 macrumors 68020

    Joined:
    Mar 4, 2007
    #3
    boot in single user mode, enable write access to the disk and type "passwd {user}" and follow the directions on the screen. If you have no admin accounts use the username root in that command and set a password for it.
     
  4. CaineMutiny, Jan 15, 2011
    Last edited: Jan 15, 2011

    CaineMutiny thread starter macrumors newbie

    Joined:
    Jan 15, 2011
    #4
    Hi ChrisMacGuy and DMMACINTYRE,

    In the meantime, I managed to enable the root account. I set a password for root, then went to NetInfo Manager > localconfig > autologin > username, and put in my original "short name" lp.

    then I logged out and was able to select from usernames, my name: Lars Price and use my original password: password and got back in!!! All my apps/settings/etc are there. All is semi-right with the world.

    WHEW!

    THEN, I deleted the user account I made for Betty (too stressful for me to worry about her. She'll probably be on this forum next week asking how to delete an original administrator account! LOL).

    The ONLY problem I have left is one UNwanted folder: that ol' darn "yn" folder that was created when I was screwing around in NetInfo Manager. Tried trashing it to no avail. It is in the Users folder. I can't even drag it to "deleted users."

    How to get rid of this?

    THANKS a bunch!

    LP

    PS The only place in the NetInfo Manager that I can find a remnant of "yn" is in
    groups > admin > property: users / value(s): (root, lp, yn)

    When you click on the users drop-down triangle, the values each go to their own line:

    users root
    lp
    yn


    Does anyone think that my computer will explode if I delete the "yn" line?

    I know, I know. I never shoulda gone there...
    ; )
     

Share This Page