Empty Dock icons after updating to OS X 10.10.3

Discussion in 'OS X Yosemite (10.10)' started by desertman, Apr 9, 2015.

  1. desertman, Apr 9, 2015
    Last edited: Apr 9, 2015

    desertman macrumors 6502a

    Joined:
    Jul 14, 2008
    Location:
    Arizona, USA
    #1
    After updating to OS X 10.10.3 (with the combo update) all Dock icons from Apple applications are only simple white icons with an "A" in them.

    This applies i. e. to Safari, Mail, Message, Systems Preferences, and others. See also attached screen shot. On top of that Mail seems to start (I can switch to it and it shows its menu bar) but does not show any window.

    Restart does not help. Repairing permissions (which I also did before updating) does not help.

    Does anybody else experiences the same? Any ideas what to do (except for going back to OS X 10.10.2)?
     

    Attached Files:

  2. TMRJIJ, Apr 9, 2015
    Last edited: Apr 9, 2015

    TMRJIJ macrumors 68020

    TMRJIJ

    Joined:
    Dec 12, 2011
    Location:
    South Carolina, United States
    #2
    Did you change the icons before hand? That Calendar icon doesn't look like the original.
    I would suggest reinstall OS X Yosemite from the recovery partition.

    Edit: My Bad. I didn't know about BusyCal
     
  3. desertman, Apr 9, 2015
    Last edited: Apr 9, 2015

    desertman thread starter macrumors 6502a

    Joined:
    Jul 14, 2008
    Location:
    Arizona, USA
    #3
    I did not change any icon. The calendar icon is from BusyCal.

    Now the (empty) Mail icon even has a red dot for new mails in it. However, it is impossible to make the Mail window visible.

    I will probably not reinstall, rather go back to 10.10.2 from a backup. But not before pestering Apple a little with it (I still have AppleCare on the iMac).
     
  4. desertman thread starter macrumors 6502a

    Joined:
    Jul 14, 2008
    Location:
    Arizona, USA
    #4
    ... just noticed that the new Photos application icon has been added automatically to the Dock - and is displayed correctly.

    I will now re-apply the combo update ... well, I would have liked it. However, Apple apparently decided to delete the 1.5 GB combo update file that I had downloaded manually from my downloads folder after the update. It really sucks!
     
  5. Taz Mangus macrumors 68040

    Taz Mangus

    Joined:
    Mar 10, 2011
    #5
    Try:
     
  6. desertman thread starter macrumors 6502a

    Joined:
    Jul 14, 2008
    Location:
    Arizona, USA
    #6
    After the second re-installation of the OS X 10.10.3 combo update the icons are finally back as they should be. I can only hope that this was the only bad surprise that this update had for me.
     

Share This Page