Empty trash doesn't free disk space

Discussion in 'macOS' started by NickMJ.Hall, Jan 1, 2010.

  1. NickMJ.Hall macrumors newbie

    Joined:
    Jan 1, 2010
    #1
    Hi,

    Macbook pro running 10.5.8

    I tried to transfer a few movies from an external disc and
    inadvertently filled my HD (or nearly filled it).
    The transfer failed, I ejected the disc, the files were gone,
    but finder was still telling me I only had about 20 Mb free.

    So I put about 20 Gb of stuff in the trash. Emptied trash.
    Emptied the trash wih the external disc connected.
    I even tried secure empty trash. Also restarted the machine.

    Finder still tells me I only have 20 Mb free.
    So does system profiler.
    So does disc utility (which incidentally tells me my HD is OK).
    I opened terminal and did a df -k, same story, only 20 Mb free.

    Except I know that I put several Gb in the trash and emptied it !

    Apart from that the computer still seems to work OK but
    something must be wrong either with disc contents diagnosis
    (at a very deep level) or with emptying trash.

    now I'm out of ideas - please help !

    thanks
    Nick
     
  2. NickMJ.Hall thread starter macrumors newbie

    Joined:
    Jan 1, 2010
    #2
    OK looks like nobody could help - but the problem has cleared itself up.
    Apparently restart was not enough, and I had to do a shutdown.
    When I shutdown, filevault spent a long time doing something and
    then when I fired up again the disk space was there.

    Nick
     

Share This Page