EMU 0404 USB crackling when recording Audio

Discussion in 'Digital Audio' started by porkvindaloo, Nov 20, 2011.

  1. porkvindaloo macrumors newbie

    Joined:
    Nov 20, 2011
    #1
    For a few months now, I have been getting crackles and pops when recording audio through my EMU 0404 USB interface. Prior to this, I had no problems for a good 9 months since buying the interface.

    I am using a Macbook Pro with OSX 10.6.8

    When I use the 0404 in my old PC (with Acid Pro 7), there is no problem. There is also no problem when I record straight into the Macbook line in.

    This is what I've tried so far, all to no avail:

    different mic
    different lead
    different DAW (tried garage band, logic, ableton)
    different Macbook (but also with OSX 10.6.8)
    moving buffer settings to highest possible
    closing all other programs
    disconnecting from the internet
    installing the latest 0404 drivers

    Anyone out there have any ideas?
    Is it a problem with OSX 10.6.8?
    I think the problem may have started after I updated to OSX 10.6.8
     
  2. zimv20 macrumors 601

    zimv20

    Joined:
    Jul 18, 2002
    Location:
    toronto
    #2
    could be a mismatch of clock rates. i.e. the setting on your device differs from the setting in your DAW.
     
  3. porkvindaloo thread starter macrumors newbie

    Joined:
    Nov 20, 2011
    #3
    Hi, really appreciate the reply. I'm a little ignorant about clock rates though. Are you able to be a little more specific?
    The EMU control panel doesn't have a clock setting that I can change. I can change the fps rate in Logic, but not sure if this is what you mean, or what to change it to....
     
  4. porkvindaloo thread starter macrumors newbie

    Joined:
    Nov 20, 2011
    #4
    The solution

    It is most definitely a problem with osx 10.6.8!
    I reinstalled osx 10.6 without doing an update to 10.6.8 and the problem is gone!
     
  5. wouter1 macrumors newbie

    Joined:
    Aug 22, 2014
    #5
    Sorry for reviving but I'm still using EMU on Mavericks. Works fine with the EMU Lion drivers. Even better than original, now I have 192kHz sampling rate (not yet tried).

    I had this problem with crackling too. It happens occasionally, maybe once per minute two or three ticks.

    I noticed the latency in Audicity was set up to 100ms. I changed it to 10ms and that seemed to solve the crackling.

    Preferences/Recording/Latency. I set both recording and playback 10 times faster.

    So maybe this issue is related to the computer waiting too long reading the data off the USB port. In Audicity you can change this wait time.
     
  6. miscend macrumors member

    Joined:
    Nov 5, 2009
    #6
    Last time I used the 0404 USB, the EMU drivers were really buggy.
     
  7. wouter1 macrumors newbie

    Joined:
    Aug 22, 2014
    #7
    I did some more recording and playback. The playback seems fine. But I did run into the crackling problem again when *recording*. I missed it earlier because the crackling seems usually a bit softer than what you are recording so it's hard to detect in pop music. But I got it when testing some click tracks. And also it seems to happen only after a few minutes of recording.

    I de-installed everything that might be interfering with the audio recording: other audio plug-ins, Airplay, wifi, whatever. Made no difference. I have 8 CPU's anyway and I never saw CPU1 above 20% during recording so this was quite unlikely anyway.

    Using different clicks each time, I figured out that the 'cracks' are actually fragments (typically around 100 samples) of previously sampled sound. I could trace back the 'source samples'. Seems that generally the 'source samples' are quite far away, like 0.12s which is 11500 samples (@92kHz).

    I did a long and deep search on this, but without driver source code it's hard to be sure. I suspect that the sampler clock runs on the E-MU itself while the USB data transport is based on a separate timer. To synchronise these, I think the EMU occasionally leaves out a few samples from a frame. There must be a bug in the drivers so that these brief changes in samplerate/frame size is ignored.


    I did not use the MIDI, so I can't comment on how buggy the MIDI part is.
     
  8. BenCarlin macrumors newbie

    Joined:
    Dec 27, 2014
    #8
    Exactly same problem

    I have the exact same problem with intermittent pops and cracking sound. So frustrating as other than that its works great. I'm running Yosemite and am using Logic Pro X for my recordings. Sound quality is fantastic with my condenser apart from these bloomin pop sounds that are infrequent but ruin a good recording!!

    I've emailed support@emu.com so will see if they can help in any way.
     
  9. wouter1 macrumors newbie

    Joined:
    Aug 22, 2014
    #9
    I really wanted to get that crackling fixed. So I wrote my own EMU audio driver (starting with the old EMU USB source code).

    It's here

    https://github.com/Wouter1/EMU-driver

    At this moment it only supports audio RECORDING (so no playback)

    I can only test on EMU 0404 USB so I'd love to hear feedback.

    So far the recording works good. No more cracking.

    Of course if you want to play back through the EMU too, you need to switch the kernel driver again after the recording is done.

    I'm now working to get the 192kHz also working on OSX. I think it can be done but the problem is again the extremely sensitive OSX timing .
     
  10. BenCarlin macrumors newbie

    Joined:
    Dec 27, 2014
    #10
    New Custom Driver

    Hi Wouter1

    It's great that you have made your own driver! I've just tried install but I get this message in command prompt:

    (kernel) Kext com.emu.driver.EMUUSBAudio not found for unload request.
    Failed to unload com.emu.driver.EMUUSBAudio - (libkern/kext) not found.
    deleting old kext
    moving things
    doing permissions stuff
    loading new kext
    Requesting load of /System/Library/Extensions/EMUUSBAudio.kext.
    /System/Library/Extensions/EMUUSBAudio.kext failed to load - (libkern/kext) not loadable (reason unspecified); check the system/kernel logs for errors or try kextutil(8).
    Can't stat /Users/bencarlin/symbols/ - No such file or directory.
    so long
    logout

    Not sure what to do!

    Thanks again,

    B
     
  11. wouter1 macrumors newbie

    Joined:
    Aug 22, 2014
    #11
    Hi Ben,

    Nice that you give this a try. That's a pretty bad start for the first user :rolleyes: Let's have a look at this

    I made a ticket for the issue https://github.com/Wouter1/EMU-driver/issues/17

    You have a git account? Then please post the answer there to avoid more discussion on that bug here . Otherwise, please post it here

    two questions to start:
    1. Can you check if there is an error message in system/kernel logs ? I think it's easiest to use the applemenu/about this mac , click on "more info" and then "system report". Select logs and then select the "Apple System Log (ASL) Messages. You can also check the console messages (Applications/Utilities/Console.app). Look for the time when you did the install.
    2. Did you get the prompt for your admin password after starting the script?
     
  12. wouter1 macrumors newbie

    Joined:
    Aug 22, 2014
    #12
    I updated the driver, I believe this fixes the problem on Yosemite (I still have Mavericks where it works fine).

    ----------

    I improved the OSX driver for EMU0404 USB. It now also supports recording at 176.4 and 192 kHz !
     
  13. ChrisA macrumors G4

    Joined:
    Jan 5, 2006
    Location:
    Redondo Beach, California
    #13
    I'm curious, what was the technical issue causing the audio defects?

    I don't know much at all about Mac OS X internals but have 20+ years experience with embedded and real time software.

    Typically serial hardware interfaces have at least small hardware FIFOs so read timing is not so critical.

    To me a Mac is just an office appliance, I work with either much smaller or much larger computers professionally. So I'm curious about what could be going on inside. Seems to me like a serious error on one party's part. I wonder how it was tested.
     
  14. wouter1 macrumors newbie

    Joined:
    Aug 22, 2014
    #14
    In this case, yes there is a "simple hardware fifo" (aka ring buffer). But it wasn't a clean implementation but bits and pieces of the ring buffer were throughout the code. But that was not the main problem.

    Looking at the symptoms of the crackling, I'm pretty sure that the technical main problem of the original driver is that it does not correctly synchronize the timers, causing the read and write head in the ring buffer to overlap.

    I think OSX is also partially to blame here. Apple has lots of documentation but still I can not find some critical information. Like what are the timing requirements (how stable does my clock have to be before the IOAudioEngine starts spitting) and how do I properly read from an Isochronous Asynchronous USB pipe. These are essential things to get right but as it is now they are just black boxes inside OSX.

    But it's a little hard to tell after all the fixes and refactoring I did before it even compiled (which is all documented in the tickets on git) and much more before I fixed the outright kernel panics at startup.

    Another big problem with the OSX driver is the poor code quality. The two main files were thousands of lines of code (they are still too large) and poorly documented on top. I think what happened is that it started as a small sample code that gradually was extended, fixed, hacked, more extended, etc, without ever getting a good cleanup and restructure.
     
  15. Emptyfruit, Sep 2, 2015
    Last edited: Sep 2, 2015

    Emptyfruit macrumors newbie

    Joined:
    Sep 2, 2015
    #15
    Hello guys. thanks for the discussion, i'm facing the same problem :(. OS X Yosemite 10.10.5. Is there any changes with the situation? Does e-mu support reply? The drivers on the official site are pretty old, but the device is still on the market, so they should care, shouldn't they?

    Update. Tried your driver: no playback. Not in Logic, not by system.

    Update: After rebooting the device on running Logic the playback woke up. Works fine :) Amazing job, thank you.
     
  16. donovan31983 macrumors newbie

    Joined:
    Nov 6, 2015
    #16
    Hi there,

    problem with iMac OS X El Capitan and audio interface EMU 0404.
    My iMac doesn't recognise the audio card!!!
    Any recommendations?
    A lot of reviews say that El Capitan has a problem with EMU.

    Thanks in advance :)
     
  17. Emptyfruit macrumors newbie

    Joined:
    Sep 2, 2015
    #17
    Look up Wouter1's driver (see above). It works on El Capitan fine for playback and midi. Recording is broken for now, though.
     

Share This Page