emulator problems (NES and GBA rom reading and sega sound)

Discussion in 'iPod touch Hacks' started by brightshadow360, Oct 12, 2008.

  1. brightshadow360 macrumors member

    Joined:
    Sep 11, 2008
    #1
    nes won't recognize my roms. every time i go in, it says that there are no roms in the directory (and yes, they are in the correct place) does the ipod touch nes require romes designed for it? if not, then what is the problem?

    a similar problem is happening for my GBA emulator. whenever I load a rom, it says that it's not an appropriate file. for both of these I have tried romes that I know work on pc emulators. despite this, even those don't work on the touch.

    finally, the sega emulator. this one works (though it is admittedly, in need of a redesign in button control and needs other improvements). the main thing bothering me though is the lack of sound. I know that it is capable of sound because I heard it when I tried to use a rom that didn't work (sonic 1 and knuckles. screen scrolled NO WAY. that brings back memories) the sound worked for this but won't work for others. any way to fix this or is this just a bug that requires fixing from the developer?
     
  2. ipodtouchftw macrumors member

    Joined:
    Jun 16, 2008
    #2
    1. Sorry, i dont know why it wont read the ROMs. just make sure its a .nes file and is in private/var/mobile/media/ROMs/NES
    also make sure the folder is named ROMs
    must have capital ROM and lowercase s
    2. you need to add the gba_bios.bin file to gpsphone.app
    search "gba bios for ipod touch willdta" on youtube and find willdta's video about
    GBA bios and follow that.
    3. Its just a bug..happens to mine too :/
     
  3. therealmrbob macrumors regular

    therealmrbob

    Joined:
    Jul 14, 2008
    #3
    gba compatibilty is low, not many games work. The nes problem I'm not sure. The gen emu is just sort of wonky sadly
     
  4. brightshadow360 thread starter macrumors member

    Joined:
    Sep 11, 2008
    #4
    found the problem with NES. apparently, the file (that it automatically created:rolleyes:) was not all capitals.
     

Share This Page