Enable GMail Push in Mail.app?

Discussion in 'MacBook Pro' started by SR71, Jun 29, 2012.

  1. SR71 macrumors 68000

    Joined:
    Jan 12, 2011
    Location:
    Boston, MA
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    Mail > Preferences > General > Check for new messages: Every minute
     
  3. SR71 thread starter macrumors 68000

    Joined:
    Jan 12, 2011
    Location:
    Boston, MA
    #3
    That isn't push email. Push email is when I get an email without the Mail.app having to check every X amount of minutes. It just comes in after it has been sent.

    Does anyone know how to enable this?
     
  4. striker33 macrumors 65816

    striker33

    Joined:
    Aug 6, 2010
    #4
    You can't as far as I am aware. Apple no longer supports it natively.

    I had to use Outlook, which is a far superior email app anyway, in order to get push emails. Chances are if you really need push email, then the small investment in Outlook is worth it.
     
  5. ericrwalker macrumors 68030

    ericrwalker

    Joined:
    Oct 8, 2008
    Location:
    Albany, NY
    #5
    Set up gmail as exhange. Not as a gmail account.


    EDIT: If that's possible on a mac.
     
  6. GGJstudios, Jun 29, 2012
    Last edited: Jun 29, 2012

    GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #6
    Edit: I found the method: Take advantage of push email servers in Mail.app
     
  7. mnsportsgeek macrumors 65816

    Joined:
    Feb 24, 2009
    #7
    There is a way to do it. It's a check box. I don't remember what it's called as I'm on my work PC. Set it up as IMAP and search google to find the check box. It's in the advanced tab or something.
     
  8. SR71 thread starter macrumors 68000

    Joined:
    Jan 12, 2011
    Location:
    Boston, MA
    #8
  9. Diego7 macrumors newbie

    Joined:
    Jul 12, 2008
    #9
  10. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #10
    Yep, it worked fine. Did you do both steps? Are you using Gmail accounts?
     
  11. Diego7 macrumors newbie

    Joined:
    Jul 12, 2008
    #11
    Yep, did both steps. I'm using a gmail account.
     
  12. SR71 thread starter macrumors 68000

    Joined:
    Jan 12, 2011
    Location:
    Boston, MA
    #12
    Try restarting your Mail.app. I had to restart mine and send a message to myself to get it to work.
     
  13. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #13
    I don't know why it wouldn't work. I've tested it on 2 Macs. Is your Gmail account set up as IMAP?
     
  14. Diego7 macrumors newbie

    Joined:
    Jul 12, 2008
    #14
    Yes, it's set up as an imap account.

    I don't recall taking any affirmative action to set it up as an imap account, but under the "Account Information" tab, the "Account Type" is listed as "Google IMAP."

    Bummer. :(
     
  15. Mojo1 macrumors 65816

    Joined:
    Jul 26, 2011
    #15
    Stoopid Mail! :rolleyes:

    The default setting for GMail accounts set-up using Mail's "Wizard" is IMAP. If you want to use POP3 you need to go offline and then you can use the wizard to configure a POP3 account. There is no way that I have found to manually configure a POP3 account when Mail is online.
     
  16. Diego7 macrumors newbie

    Joined:
    Jul 12, 2008
    #16
    Doh! I just now saw this post.

    IT WORKS! :)
     
  17. SR71 thread starter macrumors 68000

    Joined:
    Jan 12, 2011
    Location:
    Boston, MA
    #17
    Haha, I told ya!
     
  18. SlCKB0Y macrumors 68040

    SlCKB0Y

    Joined:
    Feb 25, 2012
    Location:
    Sydney, Australia
  19. BruceBack, Jul 26, 2012
    Last edited: Jul 26, 2012

    BruceBack macrumors newbie

    Joined:
    Nov 9, 2009
    #19
    Cheers. It works for the 1st mail I tested, but after then the mails still don't get pushed... Have to re-open the mail.app to get it work again -_-

    I am wondering does the iCloud account support push mail natively?
     
  20. Kayan macrumors 6502

    Joined:
    Jul 7, 2010
    Location:
    CA
    #20
    Oh man this solved my whole problem! Duh, sometimes with technology as advanced as it is, I've forgotten the good ol' restart to make the settings take effect.

    ----------

    iCloud is definitely Push enabled. I use iCloud as Push only.
     
  21. Kayan, Jul 31, 2012
    Last edited: Jul 31, 2012

    Kayan macrumors 6502

    Joined:
    Jul 7, 2010
    Location:
    CA
    #21
    Annoying Issue

    Has anyone else noticed that even after you get the "push" notifications working with Gmail/Mail, it stops working if you put your Mac to sleep and then turn it on again? I thought something was wrong after I woke up my computer until I restart the Mail app. This is inconvenient. Anyone know of a fix?

    I just discovered that this issue is solved if after you wake-up your computer, you manually hit the Get New Mail button, it seems to re-establish the IDLE connection with Gmail. Still a small pain to have to be responsible to retrieve everytime you wake-up from sleep though.
     
  22. wetrix macrumors 6502

    wetrix

    Joined:
    Dec 1, 2006
    Location:
    Auckland, New Zealand

Share This Page