Enable MacBook Pro Dedicated GPU

Discussion in 'macOS Mojave (10.14)' started by bobmusic, Sep 29, 2018.

  1. bobmusic macrumors newbie

    bobmusic

    Joined:
    Sep 29, 2018
    Location:
    Germany
    #1
    I followed these steps http://dosdude1.com/gpudisable/ to disable the Radeon graphic card in my MacBookPro 8,2

    Can anyone tell me please the steps/commands to enable the card again?

    Thanks!
     
  2. AnonMac50 macrumors 65816

    Joined:
    Mar 24, 2010
    #2
    Reset the PRAM (hold CMD-OPT-P-R) before the chime and wait for it to chime a second time, I believe it should work then.
     
  3. bobmusic thread starter macrumors newbie

    bobmusic

    Joined:
    Sep 29, 2018
    Location:
    Germany
    #3
    Thanks, I tried that but it didn't seem to work. Mojave is installed on an external SSD. In the end I ran the 10.13.6 Combo Updater on the internal SSD and that brought the AMD Radeon back to live.
     
  4. mikegasche macrumors newbie

    mikegasche

    Joined:
    Jan 21, 2019
    #4
    You need to move back the AMD kernel extensions that have been removed from the /System/Library/Extensions folder too! Basically all files that start with AMD*. If you can't find them in the root directory, where they should have been copied for recovery issues, you must get them back from your time machine. Copy them from the time machine app, not from the backup directories in the external time machine drive! Make sure they have the same user and groups settings as the other kernel extensions, recursively, since these files are packages!
     
  5. Aldyzard macrumors newbie

    Joined:
    Jan 30, 2019
  6. airlied macrumors 6502

    airlied

    Joined:
    Jul 8, 2011
  7. MadTube macrumors newbie

    MadTube

    Joined:
    May 10, 2019
    Location:
    Cape Cod
    #7
    Where do you need to enter that in Terminal? Just within the OS and reboot?
     
  8. airlied macrumors 6502

    airlied

    Joined:
    Jul 8, 2011
    #8
    within the os
     
  9. kona_pavan_kumar macrumors newbie

    Joined:
    Jun 9, 2019
    #9
    what to do to disable again
     

Share This Page

8 September 29, 2018