Enable Messages on iCloud

Discussion in 'macOS High Sierra (10.13)' started by ryxn, Jun 13, 2017.

  1. ryxn, Jun 13, 2017
    Last edited: Jun 13, 2017

    ryxn macrumors regular

    ryxn

    Joined:
    Jun 5, 2017
    #1
    Has anyone successfully used this feature yet? I have it checked on my Messages app, but it fails to actually sync. The release notes also mention that if you check your internet connection and reboot the Mac, it should work, but I've done that a few times to no avail.

    It works successfully on my iPad Pro running the iOS 11 beta though, which is interesting.
     

    Attached Files:

  2. MLVC macrumors 6502

    MLVC

    Joined:
    Apr 30, 2015
    #2
    It works on my iPhone 7+ and iPad Mini 4, but I haven't been able to get it to work on my iMac or Macbook.
     
  3. KUKitch macrumors 6502

    KUKitch

    Joined:
    Jan 10, 2008
    Location:
    England
    #3
    This is what I get on my MBP after installing the beta, alternately it works on my 12.9 and 6S+
     

    Attached Files:

  4. ryxn thread starter macrumors regular

    ryxn

    Joined:
    Jun 5, 2017
    #4
    Interesting - I haven't gotten that issue before. I bet logging in and out of Messages would fix that but I can't say for sure.
     
  5. KUKitch macrumors 6502

    KUKitch

    Joined:
    Jan 10, 2008
    Location:
    England
    #5
    That was the first thing I thought could be it, unfortunately it did not fix the issue.
     
  6. gsmornot macrumors 68030

    gsmornot

    Joined:
    Sep 29, 2014
    #6
    Mine syncs but what happens is messages from the last year return to all of my devices. I have my devices, so far as I know, all setup to delete after 30 days. With sync now, I get everything my MAC has saved over the last year. Not sure what to think of this feature yet. I want all of my devices to reflect only the last 30 days but can't seem to get them to all agree.
     
  7. em7246 macrumors newbie

    Joined:
    Jul 20, 2011
    Location:
    Colorado, USA
    #7
    I was having the same problem and I was able to resolve it by turning off "Messages on Cloud" on both my iPhone 6s and my iPad mini 4. Then I restarted messages on my MBP2016 and the option to sync was no longer greyed out.
     
  8. einsteinbqat macrumors regular

    einsteinbqat

    Joined:
    Nov 3, 2012
    Location:
    Canada
    #8
    Until we know more about the security of this, I don't think that I would enable this feature.
     
  9. jsawy3r macrumors member

    Joined:
    Jun 3, 2014
    #9
    Tried this with no luck. Ended up going through the pain of signing out of iCloud completely (System Preferences) and loging back in. Solved this problem AND got Auto-Unlock working again too!
     
  10. jon8214 macrumors regular

    Joined:
    Aug 25, 2012
    Location:
    Belfast, NI
    #10
    i can't get this activated on any of my devices I've tried logging out of iCloud restarting and signing back in but still the option is greyed out, any ideas?
     
  11. BasicGreatGuy Contributor

    BasicGreatGuy

    Joined:
    Sep 21, 2012
    Location:
    In the middle of several books.
    #11
    In beta 3, enabling iCloud Messages now works if the Mac is not connected to the internet.
     
  12. jon8214 macrumors regular

    Joined:
    Aug 25, 2012
    Location:
    Belfast, NI
    #12
    I got it activated by activating 2fa, but now can’t get it to sync any further ideas? Cheers
     
  13. ryxn thread starter macrumors regular

    ryxn

    Joined:
    Jun 5, 2017
    #13
    With Beta 3, I was able to enable iCloud Messages with everything working properly!
     

    Attached Files:

  14. mikecwest macrumors 6502a

    mikecwest

    Joined:
    Jul 7, 2013
    #14
    How does it work if it is not connected to the internet? Does it pull it silently from my iPhone with bluetooth, NFC or something?

    I noticed I had photos from my phone in the photos app, that I did NOT transfer over USB, or take any actions to transfer it.....
     

Share This Page