enable noatime

Discussion in 'MacBook Pro' started by hehe299792458, Apr 20, 2011.

  1. hehe299792458 macrumors 6502a

    hehe299792458

    Joined:
    Dec 13, 2008
    #1
    I've managed to enable the noatime command for one of my drives, the Macintosh HD drive "/", but not for my data drive "/Volumes/Data". Is there anyway I could enable it for the second drive as well?

    I used this command to enable noatime for the first drive:
    I have no idea how the code works, but I tried adding in "/Volumes/Data" string, but it didn't seem to do the trick.

    Now, I see this:
     
  2. mac8867 macrumors 6502

    Joined:
    Apr 5, 2010
    Location:
    Saint Augustine, FL
    #2
    You give so little information about your config, I am going to go ahead and assume that /Volumes/Data is actually a separate drive.

    Each hard drive will havea mount plist file. You successfully added the noatime option to your root drive (/). Verified with the format command I presume

    Now you need to find the plist file that mounts your second drive.... a simple 'grep -r "Volumes/Data" *' run from within the /Library/LauchDaemons directory should do it.
     
  3. hehe299792458 thread starter macrumors 6502a

    hehe299792458

    Joined:
    Dec 13, 2008
    #3
    Actually, they are two partitions on the same drive. My setup is as follows:

    SSD in the HDD bay, with two partition (Macintosh HD and Data). I only have this one hard disk.
     
  4. iMackPro macrumors 6502

    Joined:
    Mar 31, 2011
    #4
    ill help you out by searching everywhere i can! i really like to learn about new mac stuff lol but will you do me a favor in return and tell me what the hell noatime is? ill start searching i know what im searching for!
     
  5. D A macrumors regular

    Joined:
    Nov 21, 2008
    #5
    This works for me:

    In the terminal write this:

    Code:
    cd /usr/local/bin
    sudo nano remount_noatime
    
    Type your password and a terminal based text editor opens.

    Fill it with this:
    Code:
    #!/bin/bash
    /sbin/mount -uwo noatime /Volumes/Data
    
    Press Ctrl+X, then y to exit.

    Type this in the terminal:
    Code:
    sudo chmod +x /usr/local/bin/remount_noatime
    sudo defaults write com.apple.loginwindow LoginHook /usr/local/bin/remount_noatime
    
    Delete the plist you created for noatime for the Data volume in /Library/LaunchDaemons if you still have it.

    Reboot to see changes.
     
  6. hehe299792458 thread starter macrumors 6502a

    hehe299792458

    Joined:
    Dec 13, 2008
    #6
    Thanks a lot! That worked like a charm.
     

Share This Page