Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

Lennyvalentin

macrumors 65816
Original poster
Apr 25, 2011
1,431
793
(I searched for a thread about this, but could not find a suitable one. Sorry if I'm duplicating an existing topic.)

It seems Apple has deemed me and my (now aging, sadly) little laptop are not worthy of having transparent windows and menus (the dock background IS transparent though), because I don't see them after installing the latest public beta of Yose. This makes me a very sad panda, I was really looking forward to the new, fresher look and getting rid of all that dreary, DREARY grey that has been a staple of OSX windows for just way too long.

There doesn't seem to be any setting to enable this stuff in the system settings that I've been able to find, so maybe it has been hidden on older Macs with integrated graphics, "for my own good", as Apple is so fond of doing... :rolleyes:

Can this stuff be forced on somehow?

I generally run my MBP on a thunderbolt display, just in case it makes a difference. And no, I don't want to hear anything like I don't want this stuff enabled on my old (and yes, slow) Mac; I'm a grown man, let me worry about what I want or not, okay? :)

Thanks in advance for any suggestions/help etc!
 

phrozend

macrumors member
May 14, 2014
60
1
Hmm... might be a long-shot, but since I've seen this mentioned previously:
Have you checked Preferences -> Accessibility -> Display ?
There's a "reduce transparency"-option there that might have been toggled by accident.
 

Lennyvalentin

macrumors 65816
Original poster
Apr 25, 2011
1,431
793
Thanks for your reply! No, this is a completely fresh install of the OS - I only jumped onto the public beta ship today when the latest version dropped, figuring most of the evil bugs having been squashed by now... :) So, no toggles toggled by accident, I'm afraid.

Activating the reduce transparency option and then disabling it again makes no difference either way unfortunately. Still stuck in the dreary grey...
 

phrozend

macrumors member
May 14, 2014
60
1
That's weird. I can't remember them saying anything about certain models/GPUs not supporting it, so I guess it must be something wrong with your installation or something we're both missing. I'm sure someone smarter got a solution!
 

KoolAid-Drink

macrumors 68000
Sep 18, 2013
1,719
705
USA
Wait, are you saying your 2011 MBP won't support translucency at all? That's very baffling, because it worked just fine in ALL the DP's and Public Betas, up to PB3/DP8.

I do have a 2011 MBP 13", but it's actually being fixed up at Apple's offsite facility right now, so I'm unable to test with PB4, but can anyone else with MBP 13"s test this and confirm?

When Handoff/Continuity was disabled in PB2(?) for 2011 Mac's, Apple should've used that timeframe to disable translucency, too. Makes no sense, and I've got a feeling it's a glitch of some kind with your installation. Did you try repairing permissions? Also, try creating a new user account just to test this. Could be some kind of wonky setting with your user account.
 

ABC5S

Suspended
Sep 10, 2013
3,395
1,646
Florida
Thanks for your reply! No, this is a completely fresh install of the OS - I only jumped onto the public beta ship today when the latest version dropped, figuring most of the evil bugs having been squashed by now... :) So, no toggles toggled by accident, I'm afraid.

Activating the reduce transparency option and then disabling it again makes no difference either way unfortunately. Still stuck in the dreary grey...

It has a box to check for the grayscale
 

Attachments

  • Screen Shot 2014-09-30 at 8.28.44 PM.png
    Screen Shot 2014-09-30 at 8.28.44 PM.png
    185.6 KB · Views: 124

Lennyvalentin

macrumors 65816
Original poster
Apr 25, 2011
1,431
793
Wait, are you saying your 2011 MBP won't support translucency at all?
Ha! I don't know what I'm saying at this point!

Either it must have turned on when I toggled the translucency checkmark and I just didn't realize it - because not all windows actually show translucency - or it was on all the time and I never realized, due to the darkish desktop background I had. Also, I expected translucency to work like windows 7/vista did, which was that all windows were translucent all the time, but in Yose, only the top window with focus shows the effect it would seem.

Anyway, problem solved, so thanks guys. You were a great help! :D
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.