Carrier Enable Wi-Fi Calling on EE (UK) & Sprint (US) (Pre 8.3)

Discussion in 'iOS 8' started by Browno01, Apr 8, 2015.

  1. Browno01 macrumors regular

    Joined:
    Sep 17, 2012
    #1
    **You need a PC or Mac to do this**

    Download the EE Carrier File here

    Download the Sprint Carrier File here

    On Mac

    * Quit out of iTunes
    * Launch Terminal from /Applications/Utilities/
    * Enter the following command at the prompt and then hit return:
    * defaults write com.apple.iTunes carrier-testing -bool YES

    * Relaunch iTunes
    * Connect the iPhone to the computer
    * Launch iTunes and hold the Option key while clicking on “Check for Update” to load an .ipcc file
    * Select the .ipcc file to sync the .ipcc to the iOS device
    * Disconnect the iOS device.
    * Go to Settings, Phone and Turn on Wi-Fi Calls
    * Turn on Airplane Mode, enable Wi-Fi and the status bar should change.
    * Disable Airplane Mode and it is complete.

    On Windows

    * Quit out of iTunes
    * From the command-line, run:
    * "C:\Program Files\iTunes\iTunes.exe" /setPrefInt carrier-testing 1

    * or, for 64-bit Windows systems:

    * "C:\Program Files (x86)\iTunes\iTunes.exe" /setPrefInt carrier-testing 1
    * Nothing will appear to happen.
    * Relaunch iTunes
    * Connect the iPhone to the computer
    * Launch iTunes and hold the Shift key while clicking on “Check for Update” to load an .ipcc file
    * Select the .ipcc file to sync the .ipcc to the iOS device
    * Disconnect the iOS device.
    * Go to Settings, Phone and Turn on Wi-Fi Calls
    * Turn on Airplane Mode, enable Wi-Fi and the status bar should change.
    * Disable Airplane Mode and it is complete.
     
  2. Mabus51 macrumors 6502

    Joined:
    Aug 16, 2007
    #2
    On your sprint phone dial ##873283#
    Much easier
     
  3. appleaday6477 macrumors newbie

    Joined:
    Dec 29, 2014
    Location:
    UK
    #3
    Where can you find the carrier files? I'm on 3UK

    Thanks
     
  4. camperdown9 macrumors regular

    Joined:
    Jun 9, 2008
    Location:
    London, England & Chatillon-Sur-Seine, France
    #4
    Hi

    Wifi calling isn't available on 3UK. At the moment EE is the only network offering the service. Vodafone will offer it from the summer. I don't think O2 or 3 have said that they are going to offer the service.

    (If you go to settings, general, about the mobile network should automatically update your carrier files)

    Alex
     
  5. ghansonp macrumors newbie

    Joined:
    Apr 9, 2015
    #5

    the Shift -> check for update has no function on my windows laptop, i cant load any specific file.
     
  6. teameurox, Apr 10, 2015
    Last edited: Apr 10, 2015

    teameurox macrumors regular

    Joined:
    Oct 26, 2010
    #6
    thanks for the file for the update but am running into an issue. When I go to select to turn on wifi calling its simply stating that I must contact my carrier to enable wifi calling

    Any idea on this one?
     
  7. ghansonp macrumors newbie

    Joined:
    Apr 9, 2015
    #7
    how long

    hey how long did it take in itunes to complete the carrier update?
     
  8. davehutch macrumors 6502a

    davehutch

    Joined:
    Mar 5, 2009
    Location:
    Croxley, Herts
    #8
    Will this work on an iPhone 5 in the UK?
    For some reason EE allow the 5C to wifi call but not the 5
     
  9. Browno01 thread starter macrumors regular

    Joined:
    Sep 17, 2012
    #9
    5c and above only. Apple limited that.
     
  10. slenpree macrumors 6502a

    slenpree

    Joined:
    Apr 13, 2010
    Location:
    UK
    #10
    The cellular aspects of the iPhone 5C and an iPhone 5 are different. The former supports more 4G bands, faster 4G speeds, VoLTE and wifi calling. The latter was the first 4G phone from apple and only supported 4G on a few bands with many limitations and poor battery life on 4G.
     
  11. davehutch macrumors 6502a

    davehutch

    Joined:
    Mar 5, 2009
    Location:
    Croxley, Herts
    #11
    Ah, fair enough. My iP6 is fine but my wife might have to upgrade ;)
     
  12. ghansonp macrumors newbie

    Joined:
    Apr 9, 2015
    #12
    not working

    i have left my phone and computer on all night while the carrier settings are being updated by itunes but it doesnt ever finish....can anyone help me out?
     
  13. alFR macrumors 68020

    Joined:
    Aug 10, 2006
    #13
    Can't you just go to settings > phone > wifi calls > allow wifi calls if you have 8.3? The carrier settings updated automatically for me after the 8.3 update (EE UK).

    Edit: forget that, just saw the pre-8.3 suffix Doh! :)
     
  14. ghansonp macrumors newbie

    Joined:
    Apr 9, 2015
    #14
    Lol no problem

    thanks for the attempt, no one else seems to b replying.
     
  15. ajx8141 macrumors newbie

    Joined:
    Apr 16, 2015
    #15
    I've got the same error about having to contact my carrier to activate this service with Sprint. I called them just to check on it and they said I was the 3rd person to call about that message. I'm wondering if we are all jailbroken or not :cool:
     

Share This Page