Enabled two factor authentication on your account? Read this

Discussion in 'Apple Watch' started by Watabou, Apr 25, 2015.

Tags:
  1. Watabou macrumors 68040

    Watabou

    Joined:
    Feb 10, 2008
    Location:
    United States
    #1
    This is for the people who, like me, turned on two factor authentication on your account and are wondering why the Watch is sending messages as a text message instead of an iMessage.

    Turns out that you have to generate an App-sepecific password for your iMessages account.

    Here is what you need to do:

    1. Go to appleid.apple.com
    2. Select "Password and Security"
    3. Click on Generate App Specific Password
    4. Enter "iPhone Messages" or something similar in the "App Name".
    5. Click "Generate".
    6. Keep this window open.

    And now on the iPhone:

    1. Go to Settings -> Messages.
    2. Turn off iMessage.
    3. Turn on iMessage.
    4. In the password field, instead of your normal apple id, enter the app-specific password generated above.
    6. That's it!

    Apple Watch will now use iMessages instead of text messages.

    It's pretty weird that there's no information on this and Apple even recommends people turn on 2FA. If you don't generate an app-specific password and enter in your normal password for iMessages, the messages get sent as a text message instead, burning through your SMS total.
     
  2. Tortri macrumors 6502a

    Tortri

    Joined:
    Aug 30, 2010
    #2
    Thanks for the info! Once I get mine I'll know what to do.
     
  3. Watabou thread starter macrumors 68040

    Watabou

    Joined:
    Feb 10, 2008
    Location:
    United States
    #3
    I'm surprised that more people aren't experiencing this issue. Does it mean not a lot of people use 2FA?
     
  4. jjlannoo Suspended

    Joined:
    Oct 8, 2011
    #4
    I have two step enabled and I didn't do anything special. iMessage just worked.
     
  5. maverick808 macrumors 65816

    maverick808

    Joined:
    Jun 30, 2004
    Location:
    Scotland
    #5
    Same for me, I have 2 factor auth on and when I got the watch iMessage just worked without issue, I didn't have to do anything.
     
  6. Watabou thread starter macrumors 68040

    Watabou

    Joined:
    Feb 10, 2008
    Location:
    United States
    #6
    Interesting, did you maybe already generate an app-specific password to use for iMessage?
     
  7. iPhone1 macrumors 65816

    iPhone1

    Joined:
    Apr 2, 2010
    Location:
    San Diego, CA
    #7
    I use 2FA and my watch sends as iMessage. Might be a case-by-case glitch and not an overall issue with 2FA.
     
  8. jjlannoo Suspended

    Joined:
    Oct 8, 2011
    #8
    I may have in the past before I got the watch, memory can be flaky lol
     
  9. jst1nt macrumors regular

    jst1nt

    Joined:
    Sep 16, 2014
    Location:
    Albany, NY
    #9
    I have two factor authentication as well.... and my  watch sends them as iMessages.
     
  10. Watabou thread starter macrumors 68040

    Watabou

    Joined:
    Feb 10, 2008
    Location:
    United States
    #10
    So the issue seems to be that, if you guys have iMessage, and turn it off on the iPhone, and then turn it back on and enter your normal password, the Watch will now send them as SMS instead of iMessages.

    There's no way to go back to the old behavior WITHOUT getting an App-specific password.
     

Share This Page