Enabling Apache WebServer

Discussion in 'Web Design and Development' started by JelvisChan, Sep 5, 2009.

  1. JelvisChan macrumors member

    Joined:
    Jan 9, 2009
    #1
    I have an extreme problem with my Apache Internal Webserver, built into my iMac.

    A couple of months ago, I got the server running, started a DNS server, and made it viewable by the whole world via a DNS hostname.

    Then, for some reason, the server wasn't viewable. I checked all IPs, updated them, but still, when my computer was sleeping, no one could see my webserver.

    I rebuilt my machine, and did the following:

    -Enabled the internal PHP webserver
    -Configured my Dynamic IP by forwarding it to port 80-- xxx.xxx.x.xx:80
    -Went to http://www.no-ip.com and set up a Dynamic DNs hostname to forward to my external IP address of 87.177.61.31
    -Constantly changing, I downloaded the IP Updater to keep my external IP updated

    I then put my computer to sleep and tried the web server on another computer.
    The result: did not work.

    I went to http://canyouseeme.org and tested port 80 with my external IP and it succeeded.

    I am quite perplexed with what to do next. I have some important files that need to be shared and I need my server up. Any help would be appreciated.

    Thank you everyone,
    Jelvis
     
  2. GroovyLinuxGuy macrumors regular

    GroovyLinuxGuy

    Joined:
    Apr 2, 2006
    Location:
    Canada
    #2
    I just tried to curl your IP address and I got no reply...what type of internet connection do you have?
    A telnet to port 80 doesn't respond either.

    Is your computer connected directly to the internet? If not try that and see what happens you may have an issue with the way your port forwarding is set up.

    Don't put your computer to sleep when running the web server, just let it sit there and accept connections.

    When you said that you tried the web server on another computer, did you mean that you started a new web server on another computer or that you were trying to
    connect to the web server from another computer?
     
  3. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #3
    Web servers don't do much of anything when the machine is asleep, just like most applications. Unless you're expecting it to wake when something tries to access the web server. Doing so would still result in a slow connection though as it waits for the machine to awaken.
     
  4. JelvisChan thread starter macrumors member

    Joined:
    Jan 9, 2009
    #4
    When I say I connected to it with another computer, I mean that I tried connecting to the webserver with another computer. I typed in the DNS Hostname- http://lodcod.bounceme.net into my dad's computer and then I got a could not connect to server message.

    I am connected to the internet by a router. My router is a SpeedPort W 501V ( German ) and this is what I typed into the settings when forwarding my computer's ip:

    Server: Web-Server
    IP Address: 192.168.2.11 (my LAN IP)
    Active: [check]
    Protocol: TCP

    Port Inbound: 80
    Port Outbound: 80

    Correct?
    I can connect to the webserver when I type in the DNS Hostname on my own computer, but not on others.
     
  5. GroovyLinuxGuy macrumors regular

    GroovyLinuxGuy

    Joined:
    Apr 2, 2006
    Location:
    Canada
    #5
    As angelwatt said, do not put your computer to sleep if you want the web server to handle connections.

    Have you tried bypassing the router? Just as a step in trouble shooting?
     
  6. JelvisChan thread starter macrumors member

    Joined:
    Jan 9, 2009
    #6
    I went to energy saver and put the computer to "never" sleep, but I put the close displays to 2 minutes.

    After the displays shut off, I tested the DNS hostname again, but nothing showed up.

    How do I bypass the router? Am I doing something incorrect?
     
  7. GroovyLinuxGuy macrumors regular

    GroovyLinuxGuy

    Joined:
    Apr 2, 2006
    Location:
    Canada
    #7
    I just connected to your website and got the apache start page. Seems like it is working now.

    How much time passed between when you set up your noip account and you post your problem here? It may just have been NOIP's dns servers hadn't updated yet.

    here is the result of the curl that I just did
    Code:
    foobar:~ bs$ curl -v lodcod.bounceme.net
    * About to connect() to lodcod.bounceme.net port 80 (#0)
    *   Trying 87.177.83.18... connected
    * Connected to lodcod.bounceme.net (87.177.83.18) port 80 (#0)
    > GET / HTTP/1.1
    > User-Agent: curl/7.16.3 (powerpc-apple-darwin9.0) libcurl/7.16.3 OpenSSL/0.9.7l zlib/1.2.3
    > Host: lodcod.bounceme.net
    > Accept: */*
    > 
    < HTTP/1.1 200 OK
    < Date: Mon, 07 Sep 2009 03:39:26 GMT
    < Server: Apache/2.2.11 (Unix) mod_ssl/2.2.11 OpenSSL/0.9.7l DAV/2 PHP/5.2.8
    < Content-Location: index.html.en
    < Vary: negotiate,accept-language,accept-charset
    < TCN: choice
    < Last-Modified: Mon, 24 Sep 2007 01:12:03 GMT
    < ETag: "ec2c-5b0-43ad74ee73ec0"
    < Accept-Ranges: bytes
    < Content-Length: 1456
    < Content-Type: text/html
    < Content-Language: en
    
    snip..
    
     
  8. JelvisChan thread starter macrumors member

    Joined:
    Jan 9, 2009
    #8
    Yes I got it working.

    It actually lasted a while. Probably on my part.

    Thank you for your help and time.
     
  9. GroovyLinuxGuy macrumors regular

    GroovyLinuxGuy

    Joined:
    Apr 2, 2006
    Location:
    Canada
    #9
    Your Welcome...cheers
     

Share This Page