Enabling PHP error help

tech0925

macrumors member
Original poster
Sep 4, 2009
90
0
Hi everyone!

I recently tried to enable php errors on my imac and was getting an error saying I do not have permission to change the file. I am the admin and I know I am using the correct password. Just to double check I clicked on get info and changed the permissions of the file and it allowed me to do that. But when I try to edit the file to enable php errors it won't let me.

Any ideas?
 

amarcus

macrumors 6502
Feb 26, 2008
336
2
London, UK
A quick solution would be to copy the file to your desktop, then make the change and replace the old file with the new file (this step will require your admin password).

Adam
 

tech0925

macrumors member
Original poster
Sep 4, 2009
90
0
Hello,

I was using text wrangler to do it. Let me try copying the file and I will let you know how it goes..

Thanks!
 

tech0925

macrumors member
Original poster
Sep 4, 2009
90
0
Thanks everyone! Copying the files first and then editing works great! Everything is how I need it now. Thanks again! :D

----------

Well I jumped the gun, lol. I was able to edit the files I needed but my php error reporting is still not working. I edited the php.ini file and changed it to show all but nothing..

I currently use MAMP to build sites and I wonder if this is the reason I am not seeing php errors?

Update:

MAMP has its on files for enabling php on your mac. You will find these files in the MAMP/Conf directory. If you want to enable php error reporting, simply edit the php.ini file in the php version that you are using. In order to see the changes, you must restart the server.

Maybe this will help someone in the future :)
 
Last edited by a moderator:
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.