Enabling PHP error help

Discussion in 'iMac' started by tech0925, Nov 15, 2011.

  1. tech0925 macrumors member

    tech0925

    Joined:
    Sep 4, 2009
    #1
    Hi everyone!

    I recently tried to enable php errors on my imac and was getting an error saying I do not have permission to change the file. I am the admin and I know I am using the correct password. Just to double check I clicked on get info and changed the permissions of the file and it allowed me to do that. But when I try to edit the file to enable php errors it won't let me.

    Any ideas?
     
  2. Detrius macrumors 68000

    Joined:
    Sep 10, 2008
    Location:
    Asheville, NC
    #2
    What are you using to edit the file? Try using something that's aware of permissions, like TextWrangler.
     
  3. amarcus macrumors 6502

    Joined:
    Feb 26, 2008
    Location:
    London, UK
    #3
    A quick solution would be to copy the file to your desktop, then make the change and replace the old file with the new file (this step will require your admin password).

    Adam
     
  4. tech0925 thread starter macrumors member

    tech0925

    Joined:
    Sep 4, 2009
    #4
    Hello,

    I was using text wrangler to do it. Let me try copying the file and I will let you know how it goes..

    Thanks!
     
  5. Darth.Titan macrumors 68030

    Darth.Titan

    Joined:
    Oct 31, 2007
    Location:
    Austin, TX
    #5
    I always use a command-line editor like vi or pico to do this. That way I can issue a sudo command and edit away.
     
  6. tech0925, Nov 16, 2011
    Last edited by a moderator: Nov 16, 2011

    tech0925 thread starter macrumors member

    tech0925

    Joined:
    Sep 4, 2009
    #6
    Thanks everyone! Copying the files first and then editing works great! Everything is how I need it now. Thanks again! :D

    ----------

    Well I jumped the gun, lol. I was able to edit the files I needed but my php error reporting is still not working. I edited the php.ini file and changed it to show all but nothing..

    I currently use MAMP to build sites and I wonder if this is the reason I am not seeing php errors?

    Update:

    MAMP has its on files for enabling php on your mac. You will find these files in the MAMP/Conf directory. If you want to enable php error reporting, simply edit the php.ini file in the php version that you are using. In order to see the changes, you must restart the server.

    Maybe this will help someone in the future :)
     

Share This Page