"End" button not working?

Discussion in 'iPhone' started by TH55, Apr 30, 2012.

  1. TH55 macrumors 68030

    Nov 5, 2011
    When I try to end calls now, about 60% of the time the end button doesn't respond when I press it. It is as if the screen has a dead spot. It is annoying because it makes it look like I'm just hanging on there waiting for them to hang up or listening to them which makes me look weird or handicapped! Have you experienced this?
  2. Interstella5555 macrumors 603


    Jun 30, 2008
    Seriously? Try cleaning your screen and check your reception, hopefully people won't judge you too much.
  3. Globug macrumors 6502


    Mar 16, 2012
    Brisbane Australia
    i have the same thing happening to me. I'm running 4s 5.1 stock unlocked. :(

    The only way to hang up is to use the power button on top :(
  4. cynics macrumors G4

    Jan 8, 2012
    I've had this happen once before on my 4S. I had to kill the app from the multitasking tray worked fine after that.

    Try resetting your phone?
  5. Globug, Apr 30, 2012
    Last edited: Apr 30, 2012

    Globug macrumors 6502


    Mar 16, 2012
    Brisbane Australia
    resetting or rebooting? I restored the phone when it got unlocked and the issue is still persisting :(.

    EDIT: Just tried cleaning the screen and pressing "end" and it still didn't allow me to do so. Had to press the power button on the top again.
  6. TH55 thread starter macrumors 68030

    Nov 5, 2011
    What does my reception have to do with anything? And it's not due to a dirty screen, it's obviously a malfunction in the touch screen as it is consistently unresponsive in the same spot.

    As for being judged, that is a perfectly reasonable concern....I think the same thing when someone doesn't hang up
  7. nwmtnbiker macrumors 68000


    Apr 5, 2011
    Fidalgo Island
    Are you jb, running a custom theme? I once had that problem and ended up the themes End button was the wrong size…

    If not maybe instead of washing your phone you should clean your hands lol. Just playing:p
  8. scaredpoet macrumors 604


    Apr 6, 2007
    Consistently? The "end" button is also occupied by the dock/bottom row of apps when not in a call. Can you still launch those apps? if so, then it's not the screen.

    Have you also tried using a headset to see if you can end the call that way?
  9. TH55 thread starter macrumors 68030

    Nov 5, 2011
    Yeah my home row works fine, maybe it's not the touch sensors but it's definitely not because the "screen is dirty" like that poster above said.

    I don't own a headset. I wonder what could cause the button not to respond several times?
  10. lordofthereef macrumors G5


    Nov 29, 2011
    Boston, MA
    Sounds like a software glitch then. You tried a restore, and no go. It's a 4S, so it's under warranty. Is taking it in to Apple out of the question?
  11. 4Flynfish macrumors newbie

    Feb 27, 2013
    End Button Fix

    The fix was simple for my iPhone 5. The "End Call" button quit working last Friday evening. I updated the phone Saturday night. Problem still was occurring. I called Apple Support and a resolution was reached.

    Backup phone to iTunes and then Erase All Content and Settings.

    Then start using phone just like when you received it, without restoring from a backup. Again, do not restore from any backup.

    Feel free to make a test phone call here to make you feel better about the time investment in syncing.

    Go back to iTunes and sync with your apps, photos, music, etc.

    This worked for my phone.
  12. SoLongAndroid macrumors member

    Jan 18, 2013
    My "Answer" button is doing the same thing. So when my phone is awake and unlocked and a call comes through it takes a bunch of tries to answer. I will probably try the above fix later today.
  13. angievelrocks macrumors newbie

    Mar 15, 2013
    Re: "End" button not working - YES YES YES

    I've been experiencing this and it is RELENTLESS. My sister's iphone also does it. When I take it into the Mac store they claim that they've never heard of this before, as if I'm the only freaking person who has this going on. I'm switching back to android after having my iphone replaced 4 times and still being unable to use it for it's most basic purpose: phone calls.:mad:


    Moreover, I have reset it, powered it on and off, restored to old version, restored to new, and any other trick the genius bar had up their sleeve. They once gave me a new phone (well someone's old crap they made look like new) and i didn't connect it to icloud or anything. it was out of the box with ZERO of my stuff on it, not contacts, not pictures, nothing and went to my car which was about 50 feet away, made a phone call, and the dam thing did it again!!! Also, it's not just the end button. it's the end button, it's when i try to text, it's a variety of other very strange and glitchy things and NO I HAVE NOT DROPPED IT OR ANYTHING. These are problems I have with brand new phones they keep giving me. It's clearly Apple software and not the user. I'm looking for a new samsung galaxy and my coworker who has the III said the IV is coming out and that he's never had an unresponsive touch screen on his.

Share This Page