Endless problems with bootcamp

Discussion in 'Windows, Linux & Others on the Mac' started by Eric M B P, Feb 7, 2014.

  1. Eric M B P macrumors newbie

    Joined:
    Feb 7, 2014
    #1
    Macbook Pro
    Snow Leopard 10.6.8
    Using authentic windows 7 + snow leopard oem disc



    Hello everyone,

    Ive been a lurker on these forums over the past 2 weeks trying to get my MBP to bootcamp windows 7.. Its been very helpful! Though Ive reached a stage where im going to need to post a question of my own.

    It seems as though bootcamp is a ridiculously easy process, but for me it seems like every step I take, theres a problem at the next step taking hours to figure out how to fix.

    So everyone knows where im coming from, ill post the events of everything that has happened.

    1. Start bootcamp
    2. Choose, download windows support software (because i lost my osx disc)
    1ST ANNOYANCE:
    "The windows support software is not available"
    Apparently I read that there is no work around to this other than torrents/ buying a new osx disc.. So I borrowed one from a friend.
    3. Partition your drive
    2ND ANNOYANCE:
    My drive was fragmented so i had to defragment it, osx does not have that ability so i had to clone my drive onto a external HDD and delete the HDD on my computer and then copy my old HDD back on. (5hr process to copy/paste both times)
    4. Finally partition
    5. Insert windows 7 disc
    3RD ANNOYANCE:
    apple has some weird un addressed issue since 2008 how on some computers you cant burn DVD's..
    6. Burn windows 7 onto DVD using my brothers windows computer.
    7. Burn another windows 7 DVD because the guide never said anything about finalizing the disc
    8. Burn another windows 7 DVD because the guide didnt say anything about having to download a specific windows 7 download tool in order to boot from the CD

    ~ At this point, the cd was not working so I downloaded REFIT to boot windows 7 off of a USB. (I tried to go into the the contents of bootcamp to try to activate my computer to be able to boot off of a USB, but the lines of code did not exist.. I found out after more researching that I was basically screwed and had to boot off of REFIT.)

    9. Put windows 7 and download tool on USB because the disc did not work
    10. Run terminal commands to activate REFIT

    ~~~~~~~~~~~~~WHERE I AM RIGHT NOW~~~~~~~~~~~~~~~

    11. Boot up REFIT and select the windows drive and start windows install
    12. I Pass the screen where I select my language and Agree to terms and start to choose which partition I am on.. I select my partition with 60gb on it, and I get an error msg saying

    "windows cannot be installed to this disk. This computers hardware may not support booting to this disk. Ensure that the disks controller is enabled in the computers BIOS menu."

    So I exited out of the install and returned to OSX. I tried to repeat the process and now I get a black screen saying that bootmgr is missing and press crtl + alt + del to restart (my mbp does not have a delete key(windows version of a delete key) So I am forced to shut down the computer.

    I read up on it and it appears that windows 7 is buggy when it comes to installing from a USB...

    I tried yesterday to try again with DVD install. IT WORKED! The first time I tried to install windows 7 through bootcamp, it restarted my computer... So I tried to do it again and the 2nd time it went through..

    The 2nd time I was sent to a black screen that read - Press any key to boot from cd or dvd... So I tried clicking, and nothing happened.. I tried plugging in a external usb keyboard and nothing happened.. So i forced shutdown.

    Upon restarting for the 3rd time, it booted up the disc automatically, I passed the "press any key" prompt and I got sent to a black screen, i let it stay there for an hour, and forced another shut down because nothing was happening.

    4th attempt - Passed the "press any key" prompt and moved onto the black screen with the gray bar loading windows. It put me into the install that I got to previously when I tried to boot with REFIT.. Languge -> agree to terms -> select partition.. NOW IT WASNT GIVING ME AN ERROR! I format the drive to NTFS and I start the install..

    The install gets to the second step - expanding windows files and it hangs at 0%. I later got an error msg, though I dont recall what it said.. Windows cancelled the install and I forced shut down.

    Ive tried to restart the computer multiple times, but every time I get thrown to a black screen where it says "press any key" and then a few seconds later without pressing anything it says "Bootmgr is missing, press ctrl alt del to restart". This has happened about 10+ times.

    What do I do from here? Im beyond frustrated, it has taken me 2 weeks to get this far. Sorry if this was novelish long.. didnt want to leave anything out incase it was important.. I dont know much about computers.
     
  2. heisenberg123 macrumors 603

    heisenberg123

    Joined:
    Oct 31, 2010
    Location:
    Hamilton, Ontario
    #2
  3. Eric M B P thread starter macrumors newbie

    Joined:
    Feb 7, 2014
    #3
    I dont believe I have any ability to "Create USB stick using Apple Bootcamp Assistant."

    I cannot do it by default, and i went into the package contents and the option to boot up from a usb was not present in the info.plist
     
  4. heisenberg123 macrumors 603

    heisenberg123

    Joined:
    Oct 31, 2010
    Location:
    Hamilton, Ontario
    #4
    what version of bootcamp assistant are you on?

    it should allow you to make the windows drivers on USB
     
  5. jenzjen macrumors 68000

    Joined:
    Aug 20, 2010
    #5
    I would go almost to square one. Run boot camp assistant to delete the partion and restore your mac back to a single partition.

    I would download a new w7 sp1 iso from here (http://www.w7forums.com/threads/official-windows-7-sp1-iso-image-downloads.12325/) and google how to burn an iso to disc on osx. Make sure you pick the right version x64 or x86. Now, you should have a disc that osx likes since osx made it.

    While your machine is burning the disc, open boot camp assistant and keep trying to download the windows support software. If it doesn't work, you can manually get it from the apple support site, just depends on your machine type.

    Once you have the disc and support software, start boot camp assistant again and follow the steps. Fingers crossed, it works fine.
     
  6. Eric M B P thread starter macrumors newbie

    Joined:
    Feb 7, 2014
    #6
    im on 3.0.4.

    Ive already tried, it does not let me and the option does not exist in the info.plist

    otherwise i would have done that and not use REFIT.

    ----------


    Okay, but remember that my mac cant burn DVD's.

    I cant download the support software, ive looked it up and its a glitch with apple and it cant be downloaded online. the only fix is with a disc. Not really a big deal because i borrowed one.

    Ive also deleted my partition and re partitioned 2 times now.

    Also now, I cannot get past "bootmgr is missing" no matter of how I boot up. cd or usb.
     
  7. DeltaMac macrumors G3

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #7
    That error tells you that the Windows boot sector is damaged, or missing.
    And, that boot error is common, with easy fixes (that should also fix yours)

    You have to boot to your Win7 installer disk, and repair the boot partition for Windows.
    https://support.microsoft.com/kb/2622803
    Method 1 should be relevant, then method 2
     
  8. Eric M B P thread starter macrumors newbie

    Joined:
    Feb 7, 2014
    #8
    thanks for the reply.


    To run Startup Repair from the Windows Recovery Environment (WinRE), follow these steps:
    Insert the Windows installation disc into the disc drive, and then start the computer.
    Press a key when the message Press any key to boot from CD or DVD appears.
    If your PC does not detect the media automatically
    During the restart process, read the screen for any instructions that explain how to interrupt normal startup and enter the basic input/output system (BIOS) setup utility. Most PCs use the F2, F10, ESC, or DEL key to begin the BIOS Setup.
    Look for a tab in the BIOS Setup Utility that is labeled Boot Order, Boot Options, or Boot. Following the directions on the screen, use the arrow keys to go to the Boot Order, then press Enter.
    Locate the CD, DVD, or USB flash drive (this might be called Removable Device) in the Boot list. Following the directions on the screen, use the arrow keys to move the drive up so that it appears first in the Boot list. Press Enter. The boot order sequence is now changed to boot from the CD, DVD, or USB flash drive.
    Press F10 to save your changes and to exit the BIOS Setup Utility. Select Yes in the confirmation window. The PC will restart.
    Select a language, a time and a currency, a keyboard or input method, and then click Next.
    Click Repair your computer.
    In the System Recovery Options dialog box, select the drive of your Windows installation, and then click Next.
    At the System Recovery Options dialog box, click Repair your computer.
    Click the operating system that you want to repair, and then click Next.
    In the System Recovery Options dialog box, click Startup Repair.





    When i press any key when it flashes it for 2-3 seconds then it just turns my screen black, forever and ever will it remain black, it just hangs there. If i wait more than 2-3 seconds then thats when the bootmgr error pops up.

    Also, i cant access that "restart process" because my mac does not have a "windows delete key" i think my "delete key" is being registered as a "backspace key"

    There also lacks any information on how to "interrupt normal startup" Ill try again, but im pretty sure clicking any of the F# keys did nothing to enter any bios.
     
  9. DeltaMac macrumors G3

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #9
    You're adding about 4 levels of difficulty here…. (it's a Mac, so it's easier than it looks - no BIOS, remember?)
    1. insert your Windows installer DVD
    Now comes the "interrupt normal boot"
    2. Restart your Mac, while holding the C key.
    That's the difference! The C key forces your Mac to try to boot from bootable media, usually the CD drive -
    Soo... should boot right up to the Windows installer, where you can follow the repair directions.
     
  10. Eric M B P thread starter macrumors newbie

    Joined:
    Feb 7, 2014
    #10
    ill give it a shot, will post results.

    Just like every other step, i expect the next step to fail on me.

    thanks Delta.
     
  11. Eric M B P thread starter macrumors newbie

    Joined:
    Feb 7, 2014
    #11
    Alright, so booting up holding down "C" worked..

    It moved me to a screen where I could either start the windows setup or start windows memory diagnostics.. I did the diagnostics for the hell of it and nothing came back so I started the setup.

    I started the install to see if it would work, and it didnt.. so I went back and selected the repair and then startup repair. it returned this.

    [​IMG]
     
  12. DeltaMac macrumors G3

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #12
    Have you tried the repair using the command prompt?
    That's step 6 and 7 of the Method 2

     
  13. Eric M B P, Feb 7, 2014
    Last edited: Feb 7, 2014

    Eric M B P thread starter macrumors newbie

    Joined:
    Feb 7, 2014
    #13
    [​IMG]

    should I try to install it again? It didnt find anything.

    ~~~EDIT~~~

    It finally downloaded after 3-4 attempts. Thankyou DeltaMac!
     

Share This Page