Endless re-indexing

Archduk3

macrumors member
Original poster
Feb 7, 2012
54
0
So I love using onyx for cleaning my MBP. And recently I ran it just after updating to 10.7.5

It restarted and the usual re-indexing started of spotlight. It started on 1 hour, then 2, then 10, then 17 and now 4 days.

And progress bar does not move an inch.

I have tried shutting it off and then on again through system preferences. I have tried running onyx again. And then maintenance. Then I tried using repairing disk permissions, and no issue.

What is wrong? :O

//C
 

Weaselboy

Moderator
Staff member
Jan 23, 2005
29,403
8,989
California
Try going into Spotlight prefs and drag Macintosh HD into the exclude pane. Wait a minute. Then drag it back out. That should delete the index and start a fresh index.
 

Archduk3

macrumors member
Original poster
Feb 7, 2012
54
0
Try going into Spotlight prefs and drag Macintosh HD into the exclude pane. Wait a minute. Then drag it back out. That should delete the index and start a fresh index.
I have, which my first post suggest :)
 

fhall1

macrumors 68040
Dec 18, 2007
3,448
579
(Central) NY State of mind
From the "time machine w/10.7.5" thread - sounds like it may be applicable here:

===========
It's a known spotlight issue. https://discussions.apple.com/message/19667005#19667005

http://osxdaily.com/2011/12/10/disab...mac-os-x-lion/

If you disable Spotlight using the following command from within Terminal, Time Machine backups return to normal speed;

sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist

Once this has been resolved, you'll be able to re-enable Spotlight with the following command;

sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist
==============
 

Archduk3

macrumors member
Original poster
Feb 7, 2012
54
0
From the "time machine w/10.7.5" thread - sounds like it may be applicable here:

===========
It's a known spotlight issue. https://discussions.apple.com/message/19667005#19667005

http://osxdaily.com/2011/12/10/disab...mac-os-x-lion/

If you disable Spotlight using the following command from within Terminal, Time Machine backups return to normal speed;

sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist

Once this has been resolved, you'll be able to re-enable Spotlight with the following command;

sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist
==============
So we are yet to wait for a real fix for this?