Endless "USB Over Current Notice" Pop-ups

Discussion in 'Mac Basics and Help' started by vicki2314, Jan 2, 2007.

  1. vicki2314 macrumors member

    Jun 1, 2006
    I have received 5 pop-ups stating:

    USB Over Current Notice

    A USB device is currently drawing too much power.
    The hub it is attached to will be deactivated.

    Every time I click "OK" the window will disappear and then reappear instantly. The notices appeared when I woke my iMac G5 from sleep. I have never gotten this notice before so I unplugged my printer, iPod shuffle, and an empty USB extension cord but the notices will not go away.

    Also running at the time were Firefox and Microsoft Word. The bars on my Activity Monitor gauge are all full and my fans are running pretty loud. Also I am running version 10.3.9 on a non-isight iMac G5.

    If anyone could please help me out as to what is going on with my Mac, that would be great! Thanks!

    Attached Files:

  2. bearbo macrumors 68000


    Jul 20, 2006
    shut down computer, pull all devices, except original apple keyboard and mouse... that is, you will only have power, keyboard on the imac, and mouse connected to keyboard...

    turn on, reset PMU

    see if that helps
  3. vicki2314 thread starter macrumors member

    Jun 1, 2006

    Thank you for your reply!

    What does PMU stand for and how do I reset it?
  4. bearbo macrumors 68000


    Jul 20, 2006
  5. vicki2314 thread starter macrumors member

    Jun 1, 2006
  6. ankh macrumors member

    Jan 9, 2003
    me too -- Intel 2gHz Mini -- how?

    Had this 9 months; just started popping up the same message (while using an external USB drive to do a very long backup, but the drive's got its own power and so does everything else I have -- been using a powered hub for ages).

    I get the "USB over current" but in my case it hangs (spinning rainbow) and both keyboard and mousebuttons are ignored though the idle cursor moves around the screen; Mini has to be power cycled, as keyboard is ignored when this happened.

    Hmmm. Apple's info (Intel Mini is different)

    OSX 10.4.11.

    Any other resorts before the last one?
  7. arcanemirage macrumors newbie

    Aug 28, 2008
    My WD 500gb MyBook essential is doing it too

    It only gives one popup window with the same error. I tried resetting the PRAM and the SMC on my 2.33ghz Macbook Pro running 10.5 and it still won't work. Any ideas? It did work for awhile on it btw.

  8. fwhh macrumors regular

    Aug 11, 2004
    Berlin, Germany
    1. try a different USB port
    2. try a powered USB Hub (those with a powersupply)

    the second one was the solution to my problem with a 3.5" floppy disc drive (yeah. floppy disk.)
  9. dave39 macrumors newbie

    Oct 18, 2008
    USB over current notice and fan speed

    I have been having this notice for weeks. every time I started up the iMac 2.0Ghz Intel Titanium 2007 model, up would pop this message before I could log on. Then I also got the "roaring fan issue" with the fan going at 100% speed - some postings on this issue elsewhere. The solution or problem associated with the USB overcurrent notice is the Titanium keyboard - when I started up the imac with no USB attachments, no mouse, no keyboard there was no notice. When I plugged in the mouse - no notice, when I plugged in the keyboard - immediately got the notice. Next step was to plug the keyboard in first - immediate notice. Next step was to connect a powered USB hub with 4 ports and when I plugged the keyboard in to that I still got the notice. Eventually I tried an old Macally USB keyboard (looks old and battered) but it worked fine. Conclusion - there is something wrong with the Titanium keyboard. There have been other issues associated with the Titanium keyboard such as keyboard freezing - keyboard had to disconnected and plugged in again and also multiple strikes on keys - press a key and you got multiple entries of the character. There were Apple fixes for these problems so maybe they stuffed up again!

    Solution to the fan going at high speed - I'm not really sure but did a PRAM restart, a SMU and PMU restart which didn't help and then I did a shift-restart and it seemed to stop.


Share This Page