Endnote and MS Word

Discussion in 'Mac Apps and Mac App Store' started by Margrethe, Oct 27, 2012.

  1. Margrethe macrumors newbie

    Oct 27, 2012

    Earlier this week I used my Endnote X4 with Word 2011, no problems. Then today, I cannot get Endnote to work; that is - Word says EndNote is not responding (error code 1712).

    Has this happened to anyone else? I have recently downloaded an update to MS, but cannot remember if Endnote still worked after that update.
  2. Ja Di ksw macrumors 65816

    Ja Di ksw

    Apr 9, 2003
    Did you find any answer to this? I have Word '11 and EndNote X4, but when I click "Go to EndNote," the search tool for citations, or anything from the little Endnote bar that Word has, the button looks like it's stuck being pushed, and I can't type anywhere or do anything in Word. After a long time it finally comes up saying "EndNote is not responding. Error = -1712"
  3. facop78 macrumors newbie

    Dec 5, 2012
    Hi, Did you find any solution to this?
    It's very frustrating, I am trying to finish some documents, and I can not update my references, I basically cannot do anything, I keep getting this error 1712

  4. Ja Di ksw macrumors 65816

    Ja Di ksw

    Apr 9, 2003
  5. facop78 macrumors newbie

    Dec 5, 2012
    I found this: it worked

    EndNote: Format Bibliography freezing or giving 1712 error in OSX 10.8.2

    There is a known issue with OSX 10.8.2 that will cause Cite While You Write to either freeze while formatting or give you a -1712 (time out error). While a bit technical, this is what is currently “known” about the problem:
    The problem is specific to the OS X 10.8.2 update specifically, not EndNote or Word.
    The problem is directly related to the use of the AESendMessage/AESend functions used with typeApplicationBundleID or typeApplSignature for the target type.
    Using typeKernelProcessID for the target type still works. However EndNote uses the bundle signature.
    Killing the appleeventsd daemon fixes the problem temporarily (Antonin Hildebrand discovered this fact). This can also be done by logging out then logging back in.
    Note: We recommend those experiencing this issue should contact Apple directly. This can help prioritize the effort. Here is the link to contact Apple: http://www.apple.com/feedback/macosx.html

    To kill the appleeventsd process directly please do the following:
    If EndNote or Word are stuck, restart both applications.

    Go to Applications : Utilities.
    Run the Activity Monitor found there.
    Set the "Show" option at the top of the window to All Processes (not My Processes which is default).
    Click the column header "Process Name" to sort alpabetically.
    Highlight the appleeventsd process.
    Click the “Quit Process” button.
    Try using EndNote or Word now.

    The above indicates that the problem is likely to be some kind of stale cache used by appleeventsd for mapping bundle ids and 4-letter application signatures to process ids. It also indicates that triggering this problem involves relaunching the target application (in order to give it a new process id). This has been confirmed by a user (Torsten Grust) in the context of MailMate/SpamSieve.
    More information can also be found on the following pages:

    And many others.

    Please provide feedback on this article. In the right hand panel, indicate whether or not the article solved your problem and give us suggestions for improving it. To contact Support for additional assistance, please use the Open a Support Case tab above.
  6. bpg5 macrumors newbie

    Feb 10, 2013
    Hi facop78, Thank you for posting the solution and detailed explanation. killing the appleeventsd process solved my problem :) . Since you said that it is a temporary solution I will see if it comes back.
  7. Jobu85 macrumors newbie

    Feb 28, 2013

    Thanks for the solution (albeit temporary). I too am on tight deadlines that unfortunately rely on Endnote.
  8. jozeppy26 macrumors 6502


    Jul 8, 2008
    St. Louis
    Did you try upgrading to EndNote X6? I think the 6.0.2 update to X6 released in Jan of this year is the one that officially supports Mountain Lion.

Share This Page