Endoding in TextEdit (plain text)

Discussion in 'Mac Basics and Help' started by chomper, Dec 31, 2010.

  1. chomper macrumors newbie

    Joined:
    Dec 26, 2010
    Location:
    Central Europe
    #1
    Hello,

    I have a following problem with TextEdit. I have the "Opening Files" encoding set to Automatic. If the file I want to open is encoded in UTF-8, TextEdit detects it and displays it correctly. If the file is encoded in ANSI/i.e. non-unicode (namely Windows Latin 2), TextEdit opens it using Western (Mac OS Roman) encoding and the characters aren't displayed correctly. Where do I set the default encoding for non-unicode files?
     
  2. Caleb531 macrumors 6502

    Caleb531

    Joined:
    Oct 17, 2009
    #2
    Try the Open and Save tab in TextEdit's Preferences....

    Although, I would recommend using TextWrangler for dealing with encodings, since it makes it pretty simple (along with many other features).
     

    Attached Files:

  3. chomper thread starter macrumors newbie

    Joined:
    Dec 26, 2010
    Location:
    Central Europe
    #3
    Thanks for the great tip! TextWrangler can do the things I need - different encodings and different line breaks (Windows/Unix). However, I have one small problem: whenever TextWrangler launches, it asks me whether I want to install some command line tools. Can I switch this message off somewhere?
     
  4. Caleb531 macrumors 6502

    Caleb531

    Joined:
    Oct 17, 2009
    #4
    I would just install them (click "Yes" or "OK"), and it should go away. Doing so shouldn't hurt anything.
     
  5. chomper thread starter macrumors newbie

    Joined:
    Dec 26, 2010
    Location:
    Central Europe
    #5
    I managed to get rid of the message box by clicking "Install" and then cancelling the prompt for administrator password. :)
     

Share This Page