Energy Saver Fail after 10.6.6

Discussion in 'iMac' started by hkbladelawkhk, Jan 29, 2011.

  1. hkbladelawkhk, Jan 29, 2011
    Last edited: Jan 29, 2011

    hkbladelawkhk macrumors member

    Joined:
    May 25, 2010
    #1
    I have a 27" iMac i7. And after the 10.6.6 update, it doesn't follow the energy saver schedule. I've now had almost 2 days where it didn't AT all go to sleep, or where the monitor didn't shut off.

    Example: Last night, I fell asleep watching netflix as always. But despite the timer to go to sleep, it didn't. And the show I was watching would have been over by the time the timer went off.

    Any ideas?

    Here's what the PowerManagement Plist looks like: Note that all changes haven't been tested yet. Just guessing.

    Code:
    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
    <plist version="1.0">
    <dict>
    	<key>ActivePowerProfiles</key>
    	<dict>
    		<key>AC Power</key>
    		<integer>-1</integer>
    		<key>Battery Power</key>  (Changed this from 1 to 0)
    		<integer>-0</integer>
    		<key>UPS Power</key>
    		<integer>-1</integer>
    	</dict>
    	<key>Custom Profile</key>
    	<dict>
    		<key>AC Power</key>
    		<dict>
    			<key>Automatic Restart On Power Loss</key>
    			<integer>0</integer>
    			<key>Disk Sleep Timer</key>
    			<integer>10</integer>
    			<key>Display Sleep Timer</key>
    			<integer>1</integer>
    			<key>Display Sleep Uses Dim</key>
    			<integer>1</integer>
    			<key>Hibernate File</key>
    			<string>/var/vm/sleepimage</string>
    			<key>Hibernate Mode</key> (Activated)
    			<integer>1</integer>
    			<key>Sleep On Power Button</key>
    			<integer>1</integer>
    			<key>System Sleep Timer</key>
    			<integer>15</integer>
    			<key>TTYSPreventSleep</key> (Deactivated)
    			<integer>0</integer>
    			<key>Wake On LAN</key> (Deactivated)
    			<integer>0</integer>
    		</dict>
    	</dict>
    	<key>LastSleepUUID</key>
    	<dict>
    		<key>Date</key>
    		<date>2011-01-29T13:25:38Z</date>
    		<key>UUID</key>
    		<string>A97D6F51-D363-429E-BC79-7243B5192DDA</string>
    	</dict>
    </dict>
    </plist>
    
    I had set the monitor to sleep after 1 minute with nothing running, and counted down, nothing. This was before editing the file.

    EDIT: I tested AFTER file edits countdown timer 1 minute, gave it 1.5 mins. I deleted the plist file and let it re-create, and still nothing.

    Also note that sometimes when forcing it to sleep, it IMMEDIATELY re-wakes. I sometimes have to do this a couple times. Even with nothing running, like just now. Only safari, and not even loading anything.
     
  2. Detrius macrumors 68000

    Joined:
    Sep 10, 2008
    Location:
    Asheville, NC
    #2
    This is the epitome of when you should try resetting the SMC.

    Turn off the computer. Disconnect the power cable. Hold down the power button for about five seconds. Plug it back in. Wait a few seconds, turn it back on. Does it still have these problems?
     
  3. hkbladelawkhk thread starter macrumors member

    Joined:
    May 25, 2010
    #3
    Yes and no. I still have the issue where when I try to put it to sleep using command option eject, it goes out, and wakes right back up. I did this three times last night, finally said f it and turned it off. This is really annoying, not gonna lie. As for the sleep timer, pretty much the same, still not working correctly.
     
  4. MacHamster68 macrumors 68040

    MacHamster68

    Joined:
    Sep 17, 2009
    #4
    just repair permissions ..with the install disc, that should solve issues after a update
     
  5. PurrBall macrumors 6502a

    PurrBall

    Joined:
    Oct 25, 2007
    Location:
    Indianapolis
    #5
    What if you sleep it using the power button?
     
  6. Detrius macrumors 68000

    Joined:
    Sep 10, 2008
    Location:
    Asheville, NC
    #6
    Superstition. Complete BS.


    To the OP, try disconnecting any external devices other than your keyboard and mouse, as they may be waking the machine.

    Also, try a deeper SMC reset. That is, turn it off, unplug it from the wall, hold down the power button for a few seconds, and then just let the machine sit for a few hours. Sometimes, these things need "quiet time" for the SMC to be reset properly.
     
  7. hkbladelawkhk thread starter macrumors member

    Joined:
    May 25, 2010
    #7
    I will try that when I'm not around tonight. Thanks :). Though at current, nothing is plugged in other than USB cables not connected to anything (IE for my phone when I'm using it at my desk). Hopefully it will work, as it definitely gets annoying when I'm trying to go to sleep and my monitor keeps coming back to life. I can't imagine it's good for the HDD either.
     
  8. hkbladelawkhk thread starter macrumors member

    Joined:
    May 25, 2010
    #8
    Okay. So I left it off and unplugged for a few hours. Same thing. Off into sleep and right away it rewoke. Nothing special plugged in. I had to do it three times. My hdd probably hates me.

    Idears?
     

Share This Page