Enrypted External Hard Drives Becoming Unresponsive

Discussion in 'Mac Accessories' started by HermanTheGerman, Apr 11, 2012.

  1. HermanTheGerman macrumors member

    Joined:
    Apr 24, 2006
    #1
    I have been having the following problem lately: Both of my FilveVault 2 encrypted new externals become unresponsive upon entering the password.

    OS X gives me the beach ball of death each time and Finder becomes totally unresponsive. Even shutting down is no longer an option, given that the MBP shuts OS X down, but does not go off (the screen stays grey).

    I have all updates available through Software Update installed and repaired disk permissions. They did work perfectly fine until today but now both mutiny. :confused:

    Any help would be highly appreciated!
     
  2. HermanTheGerman thread starter macrumors member

    Joined:
    Apr 24, 2006
  3. jayhawk11 macrumors 6502a

    jayhawk11

    Joined:
    Oct 19, 2007
    #3
    Do they respond in Terminal? Type

    Code:
    diskutil cs list
    And see if they show up there.
     
  4. HermanTheGerman thread starter macrumors member

    Joined:
    Apr 24, 2006
    #4
    Yes, they do. My explanation was that my password was too long for the size of the disk. Thus, I shortened it. One drive work properly now, the other one does not. :confused:
     
  5. Mr. Retrofire macrumors 601

    Mr. Retrofire

    Joined:
    Mar 2, 2010
    Location:
    www.emiliana.cl/en
    #5
    Drive speed and password length have nothing to with each other. Encryption happens within the CPU, not on the drive.
     
  6. HermanTheGerman thread starter macrumors member

    Joined:
    Apr 24, 2006
    #6
    I was aware that decryption is handled by the CPU. However, does it not take the CPU longer if the drive has 5400 rpm and USB 2.0 in comparison to 7200 rpm and FW 800?
     
  7. HermanTheGerman thread starter macrumors member

    Joined:
    Apr 24, 2006
    #7
    Also, I tried to verify and repair the disks in Disk Utility. One shows no errors, the other one makes my Mac freeze.
     
  8. murphychris macrumors 6502a

    Joined:
    Mar 19, 2012
    #8
    No. The CPU will encrypt in exactly the same amount of time regardless of the speed of the drive.

    Are there any console messages produced for the time period when you connect the drive, enter the password, and the spinning beachball occurs?

    Are the drives directly connected to the computer? Or through a hub? The same hub or different hubs?
     
  9. HermanTheGerman thread starter macrumors member

    Joined:
    Apr 24, 2006
    #9
    The drives are directly connected to the computer via USB. I have attached screenshots of the console after connecting my external.

    Usually, one of my processor cores reaches 100%, the fans kick in, Finder becomes unresponsive, I cannot eject the drive and thus have to force shutdown the computer.

    Interestingly enough, sometimes the whole process starts upon decrypting the hard drive, then again sometimes, I get the beach ball in the middle of file transfer.
     

    Attached Files:

  10. murphychris macrumors 6502a

    Joined:
    Mar 19, 2012
    #10
    Sounds impatient. You're forcing the shutdown how?

    You know a core has reached 100% how? Activity Monitor? Or top? You should know which process is causing this. Have you taken a sample of the runaway process?


    Sounds like a hardware problem. You've used these exact same drives, same USB enclosures, same computer, without encryption and had no problems?
     
  11. HermanTheGerman thread starter macrumors member

    Joined:
    Apr 24, 2006
    #11
    First things first: I appreciate your help!

    I force the shutdown holding the power button for more than six seconds. This is all I can do. Force quitting Finder does not help at all.

    I monitor my CPU with iStat. I can see that one CPU core has reached its maximum and I hear the fans kick in - interestingly enough, I do however not see the process causing it.

    I use the same hard drives with the same computer all the time. I just bought them two months ago, used them from the very beginning with encryption and they always worked.

    Could the reason for the issue be that I did not eject the drives properly? The disks show up on the desktop and I eject them there, however, apparently, I am also supposed to eject them in Disk Utility. This has never been the case with my old externals.

    What makes the use of the new disks so annoying is that it is utterly random when they let my Mac crash. I can use them without problems, while at other times, they cause problems upon decrypting them or ejecting them.
     
  12. murphychris macrumors 6502a

    Joined:
    Mar 19, 2012
    #12
     
  13. HermanTheGerman thread starter macrumors member

    Joined:
    Apr 24, 2006
    #13
    I shut it down the way you suggested when my externals crashed again today. I gave the system 20 minutes to shut down. After that, I forced it down.

    I consulted Activity Monitor from the very beginning, there is absolutely no indication that a process requires a whole core. I have attached some screenshots for you.

    To sum it up: I do not have any problems connecting the drives. Once I enter my password for decryption, I run into troubles.

    I cannot reproduce this phenomenon anytime I have my drive decrypted, sometimes it works just fine, sometimes, the system shuts down after 30 minutes of use while transferring data to the external.

    Again, I do appreciate your help!
     

    Attached Files:

  14. murphychris macrumors 6502a

    Joined:
    Mar 19, 2012
    #14
    Yeah if you check my previous post, I said you need to change "My Processes" to "All Processes" and your screen shot shows Activity Monitor is still set to "My Processes."

    That doesn't really tell us anything because the volumes are not mounted until they are decrypted. So it's not clear if the problem is with decryption or mounting. There is an fsck.log that you could post a portion of that applies to the time the hang occurred.

    There isn't a lot of information to go on at this point. This drive has a single volume on it? Or do you have encrypted and non-encrypted volumes on it?

    Unfortunately it's very likely that the drive won't support smart monitoring. If you go to Disk Utility and click on the disk's icon (not volume, but the main disk icon that has its size and model number), at the bottom of Disk Utility you should see something about the status of SMART. What does it say?

    ----------

    Another thing you need to do is isolate which disk is causing the problem by connecting and unlocking them individually rather than together. See if consistently one of them is causing this problem.

    Also, are these USB enclosures separately powered? Or are they drawing power from USB? You might get away with this for one drive, I doubt it will work for two drives and would cause the problem you're reporting.
     
  15. HermanTheGerman, May 8, 2012
    Last edited: May 8, 2012

    HermanTheGerman thread starter macrumors member

    Joined:
    Apr 24, 2006
    #15
    I have used both of my externals today one at a time. Both seemed to work fine, until all of a sudden one of them caused me trouble again.

    Also, I have a hard time reproducing the problem. I do not even know for sure if it is just one of them or both of them. I will keep track of this throughout the next couple of days.


    One volume only, encrypted with FileVault 2.

    S.M.A.R.T. Status: Not supported.

    They both draw power from USB. I have attached another screenshot!

    Again, thank you for taking care of me!
     

    Attached Files:

  16. murphychris macrumors 6502a

    Joined:
    Mar 19, 2012
    #16
    The USB bridge chip set you're using doesn't pass through ATA commands. Therefore you can't poll the built-in SMART feature in the hard drives that periodically do testing and might give an idea if this is a disk problem at a physical level - like sector problems or read problems.



    Each drive connects to just one USB port? This is widely regarded to be unreliable. I know it seems like it's just encryption related, but so often drives draw more than a single USB bus can power. Often such USB only cases will come with cable that lets you plug into two separate USB ports so the drive gets enough power from two buses instead of one.

    So my first suspect is the drive isn't getting enough power, and occasionally gets wonky. And then the kernel is getting P.O.'d. although I'm not sure why - not a particularly elegant way to get annoyed.

    Have you tried disconnecting the drives instead of forcing a shutdown of the computer to see if the system recovers?

    Basically, all of these forced shutdowns are likely causing corruption of the journal and or the directory on the disks. And adding encryption, corrupted encrypted extents on disk may cause the problem you're experiencing as well.

    If these enclosures came with external power adapters, or a way to connect to two *powered* USB ports, I would try that. And only use one at a time if you're using USB power only.

    Quite honestly, this is one of the reasons why I'm not a fan of USB enclosures. Most of the bridge chip sets suck, and make it impossible to do SMART tests on the disks inside of them. And then there's the question of power consumption and if the disk is getting what it needs.

    So to distill this down into two suggested paths:

    1. If you can use an external power adapter for the enclosures, or two USB ports for each enclosure, do that. Best practices says that at a minimum the disk needs to be unlocked, mounted, and then repaired with Disk Utility. Ideally you'd unlock it, move data off, repartition the disk and reformat (setting it to the encrypted variety of HFS+) and then move data back. That's the only way to be sure you're gotten rid of corruption either at an encryption level or file system level.

    2. Find different enclosures for the drives that have external power. You'll still need to do file system repair at least, ideally move data off the drive, repartition with 1 encrypted HFS+ partition, then move the data back.
     
  17. SgtP3pp3r, Jul 11, 2012
    Last edited: Jul 11, 2012

    SgtP3pp3r macrumors member

    Joined:
    Mar 29, 2011
    Location:
    Honduras
    #17
    I am/was having almost exactly the same thing happen to me.

    I formatted a newly purchased 1TB hard drive, as Mac OS Extended Journaled with encryption. When first using the hard drive i had absolutely no problems, i managed to backup my computer almost completely onto it without any hassles.

    The hard drive then rested in a case for about a month, until i needed a file i no longer had on my mac, which was backed up in the hard drive. Though, at the time of creating the backup i tested the hard drive to make sure it was working, when i tried to access it a month later, it would cause the finder to crash in almost exactly the same manner described by the OP.

    It would ask for my password, i would type it in, it would let me access the information for a couple of minutes at a time, and then hard drive would become unresponsive. Furthermore, finder would become catatonic.

    I would try ejecting the hard drive to no avail (saying that the files were currently in use), i would try relaunching the finder (which would result in it not opening up again), i would try shutting the computer down (which would make it hang at the grey screen). I gave it time, hours in fact, but nothing would happen. At this point i would be forced to force a shut down using the power button.

    I tried using Disk Utility to repair, or verify and i would always get an error indicating that the process encountered an error during the verify/repair process (no further details were given).

    After trying for a very long time, and having my mac hang dozens of times, eventually i was able to access the information in the drive long enough to copy the files inside it to my hard drive and an older backup disk in which i cleared up some space. After doing this i reformatted the hard drive to simply Mac OS Extended Journaled and have been moving the information back into the drive.

    I'm VERY suspicious of the drive however, i eliminated the encryption in case that was the problem, and in all reality i don't think in my case it was the actual problem. I was actually formatting it to return it, since i am still under warranty, but since it stopped being a hassle, it's probably a waste of time to try and get a replacement at this point :p Besides, i am starting to think that its not a problem with the hardware per se, but maybe an incompatibility between the hardware and the encryption.

    I am open to suggestions however.

    Oh, and the drive draws power from USB... it has only one cable, no two headed USB port like other external hard drives i have.
     
  18. sjinsjca macrumors 68000

    sjinsjca

    Joined:
    Oct 30, 2008

Share This Page