Enter SIM PIN without restarting?

ikcikc

macrumors newbie
Original poster
Mar 12, 2008
8
0
I have my SIM PIN set - and when I switch on the phone - I get the screen that gives me 3 attempts to enter the PIN code to unlock my phone. All well and good... However - if I happen to switch on the phone and get distracted - and it goes into "sleep mode" - when I then slide the slider I no longer have the option to enter a PIN code available - I simply have "Locked SIM" in the top left corner. I can shut down the phone and start again - but its all a little bit annoying to have to do this once one has missed the short window of opportunity to enter the PIN (I have the phone set to sleep after 1 minute)...

Is there any menu option or any way to get to the PIN entry screen without restarting the phone? I would have thought that trying to make a call would do this - but no...

Any suggestions?

Thanks
 

tjk

macrumors newbie
Mar 23, 2008
5
0
I have the same prob too. However by making a call it used to give u the option this was with firmware 1.1.1. This doesn't work anymore so I guess its a bug?
yep, tried many things. calling, writing sms, changing pin even... nothing brings the menu back in 1.1.4
 

NeoMayhem

macrumors 6502a
Aug 22, 2003
916
1
Same problem. I thought that turning Airplane mode on and off would do it, but it doesn't work.

The only thing I have had work is popping the sim out and putting it back, or restarting.
 

Snookerman

macrumors 6502
Jul 6, 2008
391
9
I just updated to 6.1 in my iPhone 5 and wasn't even prompted to enter my PIN. I looked around in the settings and tried to make a phone call but still no PIN prompt. I guess you still have to restart you iPhone to unlock your SIM.
 

Nale72

macrumors regular
Nov 13, 2012
216
0
Sweden
I just updated to 6.1 in my iPhone 5 and wasn't even prompted to enter my PIN. I looked around in the settings and tried to make a phone call but still no PIN prompt. I guess you still have to restart you iPhone to unlock your SIM.
Settings - Phone - SIM-PIN

I had the other way around. Since the last update i haven't been promted to enter my SIM Pin, not even after a reboot, and have been able to make calls anyway. So my SIM Pin was useless before, even tried to deactivate and reactivate with no effect.

After the 6.1 update however, I was promted to enter the pin again, so I thought it was a bug they had fixed with 6.1.
 

Snookerman

macrumors 6502
Jul 6, 2008
391
9
Settings - Phone - SIM-PIN

I had the other way around. Since the last update i haven't been promted to enter my SIM Pin, not even after a reboot, and have been able to make calls anyway. So my SIM Pin was useless before, even tried to deactivate and reactivate with no effect.

After the 6.1 update however, I was promted to enter the pin again, so I thought it was a bug they had fixed with 6.1.
I tried that but it didn't work; I only got the two grayed out options and no prompt.

However, I tried it now after restarting and it does work. I guess there was a bug right after upgrading which is why I wasn't prompted at the start or in the settings.
 

Turtlecove1

macrumors newbie
Mar 12, 2017
1
0
I have my SIM PIN set - and when I switch on the phone - I get the screen that gives me 3 attempts to enter the PIN code to unlock my phone. All well and good... However - if I happen to switch on the phone and get distracted - and it goes into "sleep mode" - when I then slide the slider I no longer have the option to enter a PIN code available - I simply have "Locked SIM" in the top left corner. I can shut down the phone and start again - but its all a little bit annoying to have to do this once one has missed the short window of opportunity to enter the PIN (I have the phone set to sleep after 1 minute)...

Is there any menu option or any way to get to the PIN entry screen without restarting the phone? I would have thought that trying to make a call would do this - but no...

Any suggestions?

Thanks
SOLUTION: All iPhones: Settings > Phone > SIM PIN
 
Last edited:
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.