Entering formulae in Pages tables

Discussion in 'Mac Apps and Mac App Store' started by malking, May 28, 2014.

  1. malking macrumors newbie

    Joined:
    May 28, 2014
    #1
    Hi everyone,

    I started using Pages a couple of days ago, and I just realized you can insert formulas into tables' boxes.

    However, it looks like I'm missing a step to make it work.
    Reading the Pages 09 (my current version) manual instructions it seems like I only need to do what I'm used to do on Windows Excel, but that doesn't work here: after I'm done using the editor to enter the formula, the box still shows the formula instead of its result.

    I guess I'm missing something very obvious, yet I'm not able to figure out what it is. :eek:

    Hopefully someone can quickly help me out, thanks in advance!
     
  2. malking thread starter macrumors newbie

    Joined:
    May 28, 2014
    #2
    I'll add another question:

    how can I get rid of the little square with a + inside that appears in every box of my table? :confused:
     
  3. snberk103 macrumors 603

    Joined:
    Oct 22, 2007
    Location:
    An Island in the Salish Sea
    #3
    Have you started the formula with an 'equals sign = '?

    So, =(A3+A5+A8)

    A little black 'lozenge' should pop up where you actually then type in the formula. It is important to then click on the green check-mark. I don't know that tapping the Return Key always works - if it works at all.

    The little box with the plus sign tells you that there is more content than will display in that cell. Make the cell bigger. Sometimes it will be 'invisibles' that are to blame. Page Returns, Tabs, etc. So the cell content may look like it should fit, but there will be formatting commands that then extend the content. Look for "Show Invisibles" in the Menu Bar... I think under View. This will show you things like Tabs and Spaces and Hard Line Returns.

    This is useful during a final edit, and also for doing a Search and Replace. You can copy and past two spaces into the Search box and Replace them with one space.

    ----------

    Hope this helps.
     
  4. malking thread starter macrumors newbie

    Joined:
    May 28, 2014
    #4
    Thanks a lot for taking the time snberk.


    all that was done but still didn't work.

    I thought I had already tried all the different box formats, but apparently not: setting it to automatic the operation result finally shows up instead of the operation itself. So that's solved. Can't believe in my tries before posting this I didn't try the right format.


    I'm using Pages with the 'show invisibles' setting turned on.
    The boxes are bigger than the numbers and there are no invisible characters there. And in fact even if I make the boxes bigger, the damn little box won't disappear.
    :confused:
     
  5. snberk103 macrumors 603

    Joined:
    Oct 22, 2007
    Location:
    An Island in the Salish Sea
    #5
    :) It's what makes this a nice place to spend time.
    Ah yes... the learning curve... when we finally figure out how to do something right, even though we've been doing that way already without results. Trust me... I know the feeling.
    There's something there still, in all likelihood. Did you type in the content or paste it in? Also... watch out for the Inset Margin. But there could be an "insert page" way way down... or something like that.

    In the Inspector, check the Text tab... (Big T). The bottom of that tab should be the Inset Margin ... i.e. the amount of white space around the text. If memory serves these settings can be context sensitive... so make sure the cursor is in a cell with the plus sign.

    Also in the Inspector, on the Table tab, is a setting to Automatically Resize to fit the content. See what that does for you. I can't remember if it will resize a cell to fit content already in place, or if it will only resize as you add content. But play with that to see if it solves the issue.

    I'm going to also suggest you look for the iWork community support forums on Apple website. We're a bunch of happy, fun, argumentative nerds here... but we don't really know that much about iWork. The real experts are over there. Not nearly as much fun though.
     
  6. malking thread starter macrumors newbie

    Joined:
    May 28, 2014
    #6
    THIS

    turns out the ****ing tables i was provided with had an inset margin.
    So taking that away the little + box finally goes away. However, doing that the text instead of staying centered moves upwards in the box, because of the font that was used (i guess to make it centered despite the margin).
    Since the font can't be changed anymore, i'll have to live with the damn little box for the next week and hundreds of tables unless it is possible to turn it off while leaving the inset margin as it is.

    If anyone knows about it please let me know.

    Oh, and thanks again for your help snberk!


    As for the iWork community support forums, I gave up after realizing how much info you need to provide just to be able to subscribe to their forums.. I wondered if moving forward they would also ask for a credit card before being done, jeez
     
  7. snberk103 macrumors 603

    Joined:
    Oct 22, 2007
    Location:
    An Island in the Salish Sea
    #7
    I think, maybe, you need to spend a bit more time learning some of the formatting basics. The fonts can absolutely be changed, under normal circumstances at least. Within the Inspector and/or Toolbar there are ways justify the text Left, Right, Centred both vertically and horizontally.

    Not sure what you are trying to accomplish, so many of these suggestions are very unspecific and generalized.
     
  8. malking thread starter macrumors newbie

    Joined:
    May 28, 2014
    #8
    ahah looks like i've come around as a complete noob.. but i know at least how to change fonts and centering stuff under normal circumstances.

    What i meant is, I'm not allowed to change the fonts (that limitation has nothing to do with the software), and applying the tools to reset text vertically and horizontally won't change anything because that was already done. The problem is, with the inset margin that was set, the used font will make appear the table header text in the middle of the boxes, whereas if I take the inset margin away, that text will move closer to the upper line of the boxes, simply because of the way that font is.
     
  9. snberk103 macrumors 603

    Joined:
    Oct 22, 2007
    Location:
    An Island in the Salish Sea
    #9
    Ahh... I misunderstood. External restrictions. Am I right in thinking that if you don't make the font/formatting changes then the table is difficult to work with - but when you give it back to the person you got it from you have to put it all back they way you found it?
     
  10. malking thread starter macrumors newbie

    Joined:
    May 28, 2014
    #10
    pretty much... yes I have to give it back the way i found it, and the little boxes sometimes cover some text/numbers.

    Anyway, I got a more serious problem now:

    after adding a lot of tables, the Pages file has become so slow that it makes very difficult to work on it in reasonable time.
    The computer is still fast on the other stuff, and even on other smaller Pages files, but the big one is becoming a disaster.

    Is there a way to enhance Pages' performances?
    Like dedicating more cache than originally set by default?

    thanks a lot to whoever will help on this one..
     
  11. snberk103 macrumors 603

    Joined:
    Oct 22, 2007
    Location:
    An Island in the Salish Sea
    #11
    Can't help you here... that kind of guru-ness is above my pay-grade. There are true gurus on the Apple Support forums.... so you'll have to decide whether it's worth it. There may be other Pages support groups as well. There is a poster on here on MR who is a Pages guru... Peggy D. See if you can search her out. Maybe she can help.
     
  12. malking thread starter macrumors newbie

    Joined:
    May 28, 2014
    #12
    Thanks again man, I'll certainly try that route as well!
     

Share This Page