Epson 4870 scanner, options grayed out

Discussion in 'Digital Photography' started by 617arg, Apr 15, 2008.

  1. 617arg macrumors 6502

    Joined:
    Mar 3, 2008
    #1
    I posted this in the Peripherals forum but got no response. I'm hoping I might have better luck here since I've seen a few posts dealing with scanners in this forum.

    I have an Epson 4870 scanner which I connected to my new Mac in order to scan some negatives. I downloaded the latest Mac drivers from Epson, but for some reason the option for "film" is grayed out in professional mode, and doesn't exist at all in home mode.
    When I reconnected it to my PC all the options were there, but I really want to be able to use this scanner with the Mac.
    Can someone who is using this scanner guide me in how to enable full functionality? I'm getting a bit frustrated in that this is my second pricey peripheral which is listed "Mac compatible" but seemingly crippled of some main features.

    Thanks for any help
     
  2. ChrisA macrumors G4

    Joined:
    Jan 5, 2006
    Location:
    Redondo Beach, California
    #2
    The option is greyed out depending on how other options are set. I do have a 4870 and I've scanned both negative and positve film in "profesional mode" so I know it works. So look at the other options. I don't havetime right now to look. Send a PM if you still can't figure it out I can look tonight

    Worst case is you have to use different software like vuescan
     
  3. 617arg thread starter macrumors 6502

    Joined:
    Mar 3, 2008
    #3
    Thanks for the reply ChrisA. It's good to know that it does work.
    I don't remember there being many options to play around with (on Epson Scan at least), but I will try messing around with the options a bit more once I reconnect it to the Mac.
    I appreciate your time in giving me a response (and some hope!)
    Thanks
     
  4. jduffany macrumors newbie

    Joined:
    Feb 19, 2010
    #4
    I am having the same problem. I just reinstalled the Epson Scan software, & rebooted. I followed ChrisA's advice & dug through all the limited options I could. Nothing works. The crazy thing is that it was working just last week. I use it all the time to scan film. I scanned some documents the other day & now "Document Type" has "Film" all gray'd out. What gives?
     
  5. rosenqvi macrumors newbie

    Joined:
    Mar 20, 2010
    #5
    Exactly the same happened to me.
    I solved it by unplugging and plugging the lid cable.
     
  6. Mac$ki macrumors newbie

    Joined:
    Nov 30, 2010
    #6
    Fix for grayed out Film option

    Had the same issue on Epson Perfection 4870 Photo.
    The fix is to reinstall the white mat inside the lid. See the picture.
    Restart the Epson software and scanner, Film option should be back.
     

    Attached Files:

Share This Page