Epson DX6050 on OS X Leopard 10.5.4 - driver help?

Discussion in 'Mac Basics and Help' started by Peter Crowder, Jul 13, 2008.

  1. Peter Crowder macrumors newbie

    Joined:
    Jul 11, 2008
    #1
    Hi,

    I've been trying for the past three hours to get this printer working under OS X!

    It's shared from a Windows XP PC. I can see it in Print and Fax, I can add it alright and I've installed the latest drivers from the Epson site (which also installed the EPSON Print utility). However whenever I try and print, the utility opens but the print job is always 'stopped'. I've tried with the Generic PostScript driver but the most I get is pages and pages of code, whatever I try and print.

    I've gone as far as deleting everything EPSON, restarting, reinstalling the drivers and trying again (this includes things from the /Library/Printers folder, if it makes any difference) but it still doesn't work.

    Ideas and input would really be appreciated; I'm at my wit's end!
     
  2. Peter Crowder thread starter macrumors newbie

    Joined:
    Jul 11, 2008
    #2
    Apologies for double posting, but I've got a solution, albeit a bit MacGyvered.

    I'm using the Gutenberg drivers which came with OS X for the Epson Stylus DX4800. Printing occurs without any problems, so need I be bothered about using another printer's drivers or not?

    Thanks!
     

Share This Page