Epson EPL-5800 won't print on new IMac

Discussion in 'Mac Accessories' started by bobanderton, Oct 8, 2007.

  1. bobanderton macrumors newbie

    Joined:
    Oct 8, 2007
    #1
    Hi, I have recently got a brand new iMac, but seem unable to get my old EPL-5800 printer to work with it.

    I have downloaded and installed the drivers from the Epson website, and it recognises that the printer is there, but then when asking it to print it gets stuck saying 'waiting for device', before eventually coming up with 'communication error. I have checked all the connections, and the printer will happily print a status sheet.

    Does anyone have any idea what might be the problem.

    Thank you

    Bob
     
  2. ed. macrumors member

    Joined:
    Jan 31, 2008
    #2
    Hi,
    I'm experiencing the same problem with the same printer, I'm on a white 24" iMac with Leopard 10.5.1 and as far as I can remember the printer worked ok until christmas (I started a three weeks trip then, and I remember having printed all kinds of maps and sheets for my journey). Then just yesterday I needed to print something and all kinds of errors popped up: offline errors if I use the printer connected to the apple keyboard, or waiting for device or worse postscript font errors if I connect it directly to the mac. With a little of fumbling I managed to print a couple of sheets, but I cannot reproduce the procedure (sigh), and however it required restarting the printer after every print.
    I really can't place the error here, since the printer worked fine after the last update (10.5.1) and I can't see other significant updates that could have affected the printer. Also, if I try to download 'new' drivers from epson, the installer says that the same driver is already on the system and it doesn't need to go on.

    On a side note: my toner is almost finished (the *half* filled cartridge that came with the printer!), and a new cartridge would cost me as much as 130 euros... a new cheap laser printer would be less than 100, I'm starting to do some math...
     

Share This Page