epson printer

Discussion in 'Mac Apps and Mac App Store' started by trainguy77, Apr 3, 2005.

  1. trainguy77 macrumors 68040

    Nov 13, 2003
    I am never going to get another epson.

    One of the computers(10.2.8) in my house is having printer problems. It is a epson printer. I was attempting to make this computer work with another epson printer which was connected to airport extreme. I could not get it to work so i contacted epson. They said to install the latest drivers, which i went and did. This changed nothing. When i print to it just prints half the page then stops. So after a couple replys from epson i gave up and just shared the printer on another 10.3.8 computer, this worked fine.

    Now my second printer is hooked up directly to the 10.2.8. No longer works with the computer so i installed the drivers for this printer. I have got it working, but with a couple problems. When print PDF it will take up to 5 minutes a page, It will change fonts with some documents on page 2. I used to use the drivers that came with mac OS X. How can i get the drivers that came with 10.2.8?
  2. Bear macrumors G3

    Jul 23, 2002
    Sol III - Terra
    How about mentioning the printer models? The types of computers and such?
  3. trainguy77 thread starter macrumors 68040

    Nov 13, 2003
    The computer with the problems is running 10.2.8 as i mentiond the printer that is not working localy is a epson 660I. The printer not working from the base station is a C80, which works fine from 10.3.8 machines.
  4. Macky-Mac macrumors 68030


    May 18, 2004

    that's odd....makes me wonder if it's your printer at all. I assume you mean this happens when you go to print a document and select the "save as PDF" button??? For me, that works just fine even when there isn't a printer hooked up to the if you are having problems with this feature of OS X, then it might not have anything to do with the printer or the printer drivers
  5. trainguy77 thread starter macrumors 68040

    Nov 13, 2003
    No it is when i open PDF files and try to print them. I am using gimp drivers because i could not get the espon ones to work, what so ever. I would like to use the epson drivers but after i install them i go to add printer it says no drivers found. So i need to know how to restore the os x drivers, they worked fine.
  6. LeeTom macrumors 68000


    May 31, 2004
    I could be mistaken.. but I thought that some Epson printers installed the drivers in a funny way. So that instead of choosing USB Printer or Rendezvous from the drop down box, look to the bottom of it and there are a whole slew of Epson style drivers, like Epson USB Printer, and Epson Rendesvous Printer, etc.
    Yes? No?
  7. trainguy77 thread starter macrumors 68040

    Nov 13, 2003
    There is a section for epson printers, but it does not even show the printer there.

Share This Page