Epson scanner not working after upgrade to Sierra

Discussion in 'macOS Sierra (10.12)' started by nigelbb, Nov 6, 2016.

  1. nigelbb macrumors 6502a

    Joined:
    Dec 22, 2012
    #1
    I just updated to Sierra & the scanning function on my new Epson WF-2750 no longer works. When I try & access the scanner from System Preferencesor Preview or Image Capture I get the error message :-
    An error occurred while communicating with the scanner. (-9923)

    Printing works OK & scanning worked in El Capitan before I upgraded to Sierra. I booted off a backup disk & confirmed that scanning still works OK with El Capitan

    I have already downloaded & run the latest driver install but this made no difference I still get the error

    An error occurred while communicating with the scanner. (-9923)
     
  2. nigelbb thread starter macrumors 6502a

    Joined:
    Dec 22, 2012
    #2
    I just discovered the this is not a Sierra issue. Oddly enough it occurred after I installed a new modem/router in anticipation of going live tomorrow with Superfast fibre. I had problems as it froze for a few seconds every few minutes so swapped back to the old modem/router & now there are no problems. It must be a Bonjour or WiFi problem I know that the new modem/router has a single SSID for 2.4GHz & 5GHz whereas the old unit is 2.4GHz only.
     
  3. dmrowley macrumors 6502

    dmrowley

    Joined:
    Aug 4, 2010
    Location:
    Dortches, NC
    #3
    I get the same error with my Epson DS-30 portable scanner, but it works fine with VueScan. Really annoying.
     
  4. nigelbb thread starter macrumors 6502a

    Joined:
    Dec 22, 2012
    #4
    I have done some more testing & narrowed the problem down & it's definitely the new Huawei HG633 from my ISP TalkTalk that is responsible for the problem. I switched back to the old router & the problem went away. I set up the printer with WiFi Direct (makes the printer a Wireless Access Point that I connect to directly from the Mac) then it scans OK.

    Googling around this issue is relatively common but nobody seems to have a proper diagnosis probably because most of the time they don't realise that it's a problem with the router.

    On my home network I have a Time Capsule set up with its own SSID but using the router as DHCP server but even connecting both printer & Mac to this WiFi network the error still occurs. Replace the new router with the old but still have the printer & Mac connected to the Time Capsule network & I can scan via Image Capture & Preview once more.

    I have now upgraded to VDSL fibre so am forced to use the new modem/router as the old modem was ADSL only so am still looking for a solution. I cannot figure out why the router would impact network traffic on the LAN maybe it's a dodgy implementation of Bonjour or something? The printer is accessible by TCP/IP & both printer & scanner appear when I sniff around with a Bonjour browser.
     

Share This Page