Erase/delete iCal event

Discussion in 'Mac Apps and Mac App Store' started by riklar, Aug 16, 2009.

  1. riklar macrumors member

    Joined:
    Jul 23, 2006
    #1
    Hello,

    I have entered an event to ical, which repeats itself everymonth.
    I want now to erase it.
    I click on the event, then I click on Delete in my keyboard. I get a dialog box asking me If I want to delete all future event. I click to OK and the event is not erased. It continues to appear.

    How can I convince this event to disappear forever.

    TIA

    iMac 24 Mac OS X (10.5.7) iPhone 3G 3.0
     
  2. tallguy macrumors regular

    Joined:
    Jun 11, 2008
    Location:
    Canada
    #2
    Are you clicking on the option to delete all future events or just the selected event?
     
  3. riklar thread starter macrumors member

    Joined:
    Jul 23, 2006
    #3
    I click to delete all future events as well, but this time it doesn't work as usual
     
  4. MKSinSA macrumors regular

    MKSinSA

    Joined:
    Aug 1, 2009
    Location:
    Alamo City, Lone Star State
    #4
    Try going to the second instance

    of the event and "Delete All Future Occurrences" from there. If that makes those disappear, go back and take out the original. Don't know why but sometimes it needs to go that route.

    HTH and Cheers! :cool:
     
  5. MacManNM macrumors newbie

    Joined:
    Sep 21, 2008
    #5
    How to fix ical events and calendars that can't be deleted

    Yeah, I had same problem too, and only way I found to delete those calendar items without them coming back is this:

    I just found a solution: Go into iSync, (use macintosh HD, applications), then go to Preferences. Turn off iSync (uncheck enable syncing on this computer). Then Reset Sync History (be sure to push Reset Sync History on second screen too). Then logoff/logon or reboot. Then you can delete calendar events or calendars or whatever you need. If you need to sync again, just go into iSync and re-enable syncing. The problem does not seem to come back. I tried all the other solutions posted and none worked except for this one.
     

Share This Page