Erase failed - Could not unmount disk

Discussion in 'MacBook Pro' started by sisop, Nov 27, 2012.

  1. sisop macrumors newbie

    Joined:
    Nov 27, 2012
    #1
    Dear all,

    I am having a serious problem with my MBP 13, 2010 and need a help urgently... :(

    Two days ago i got my 10.6.8. crashed. Trying to reboot did not work. After i boot it from original MacOs DVD i tried the following


    (1) Repair with Disk Utility - upon the process, two allert messages appear - "Volume bitmap needs minor repair for under=allocation" and "Volume header needs minor repair". Finnaly i have "Was repaired successfully" from it

    (2) I could also Verify disk permissions successfully

    (3) For doublechecking run "Disk verify" again receiving "The volume Macintosh HD appears to be OK" as result

    Nonetheless, after that...

    (3) if i tried to format with Erase i got "Volume erase failed with the error Could not unmount disk"

    (4) if i tried to resize the Macintosh HD partition in Partition window, it returns the same - "Cannot be resized Could not unmount disk"

    (5) if i tried to recover the entire system from the Time Capsule backup, the error message appears immediately offering to reboot and try again

    (6) if i tried to simply reinstall the system, the process seems to start at first but after a couple of minutes stops with the message "Install failed, MacOs could not be installed on your computer, the installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance. Click restart to restart your computer and try installing again"

    Interestingly, if i reboot and try to repair disk again, the very same mistakes appear, even thogh they have been detected and fix just before reboot

    Do you have any idea what else can be checked?

    thanks in advance...
     
  2. sisop thread starter macrumors newbie

    Joined:
    Nov 27, 2012
    #2
    Update...

    somehow i managed to delete the initial partition, so now if i try to create a new one i receive POSIX reports either "cannot allocate memory" or "input/output error". Commands l;ike diskutils and fdisk run from terminal don't work either... Seems to be a hardware problem :( ....
     
  3. switon macrumors 6502a

    Joined:
    Sep 10, 2012
    #3
    RE: booting from external drive?

    Hi,

    Sorry about your troubles. Have you tried booting from an external drive, either a clone of your boot drive or an "install USB"?

    Good luck,
    Switon
     

Share This Page