Erasing Freespace Not Working

Discussion in 'OS X El Capitan (10.11)' started by immobilus, Dec 29, 2015.

  1. immobilus macrumors member

    Joined:
    May 5, 2012
    #1
    Hi All"

    Trying to securely erase the freespace on my macbook's internal hard drive. I do it monthly. and it has always worked.

    Now when I enter 'diskutil secure erase freespace 3 /dev/disk0s2' in terminal, it gives me the following error: "Erasing freespace only works with a drive that is mounted and writable." It says this regardless of whether the drive actually is mounted and writable. I've tried logging out and erasing the freespace in terminal from recovery mode, and I get the same error despite disk utility saying that the drive is mounted and writable. I've tried from safe mode for the same result. I even tried in single-user mode, and of course the diskutil framework does not work in that situation in general.

    I've googled this question for hours. Nothing.

    I've tried manually mounting the hard drive using 'mount -rw /' and fsck, and it says the drive mounted successfully. I've tried using 'diskutil mountDisk /dev/disk0s2' and it says the volume was mounted successfully. The drive is mounted and writable, but the secure erase function off diskutil seems to believe to the contrary.

    Where am I going wrong?
     
  2. Riwam macrumors 6502a

    Riwam

    Joined:
    Jan 7, 2014
    Location:
    Basel, Switzerland
    #2
    *******
    Many users disappointed of the new DU have installed the previous DU.
    I even found in the web a mac user who put it in a torrent.
    Now I have in my utilities folder both the new crippled and the previous DU.
    It might be worth trying what you need with the old DU.
    In any case it is useful for other tasks no longer available if you just have the present limited DU.
    Ed
     

Share This Page