Erasing Hard Disk --- 7 hours on now---normal?

Discussion in 'Mac Basics and Help' started by SwitchingSoon, Sep 6, 2010.

  1. SwitchingSoon macrumors regular

    Joined:
    Apr 14, 2004
    Location:
    Saint Louis, MO
    #1
    Hi, for some reason, one of the internal hard disks I bought for my mac pro wasn't showing in my finder. It shows up in disk utility--just not the finder. I wasn't sure what to do, so I decided to "erase" it (even though I never used it), and then to reinitialize it, or whatever, with the hope that it shows up in finder.

    So, I chose to erase it some 7 hours ago, and I still get the message "unmounting." Is this normal? The drive is a TB, so is that why it's taking so long?
     

    Attached Files:

  2. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #2
    If it's stuck at unmounting, something is wrong--that step should only take a few seconds. Normally I'd expect an error after a while, but you're obviously not getting one. Unless you're dong a secure erase of the drive, the erase procedure should only take a few seconds in total.

    Given that you're already having issues, it's at least possible that there's actually something wrong with the drive mechanically. Or could just be a software glitch; start by restarting the computer and trying it again, to see if it reformats correctly.
     
  3. SwitchingSoon thread starter macrumors regular

    Joined:
    Apr 14, 2004
    Location:
    Saint Louis, MO
    #3
    Thanks.

    I stopped it.

    I'm doing the repair disk. Do you know how long this should take?
     

    Attached Files:

  4. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #4
    Seems like that drive is damaged / defective.
     

Share This Page