Erasing the boot camp portion of my hardrive

iEugene

macrumors regular
Original poster
Apr 18, 2006
137
0
AZ
Hey everyone. About a few weeks ago I tried to install boot camp, and it completely screwed up my Mac. It was either because it wasn't Service Pack 2 (it was actually a burned copy of some XP Professional) or that I accidently installed it over OS X. Something like that. I had to re-install OS X twice to get it back to normal and lost all of my files (except for my music).

Everything has been back to normal since then, and I'm slowly getting my files back. But something bothers me, my hardrive still has 5 gigs available to boot camp.

When I open Disk Utility, I can select either the Macintosh HD, my iPod, or what reads, "disk0s3". It is gray unlike the others which are black. I tried to erase it said it couldn't.

Is there anyway to get that portion of my hardrive back? Or is it lost forever?
 

Xander562

macrumors 68000
Apr 2, 2006
1,628
0
Open the Boot Camp Assistant again, and you should be able to remove it that way.
 

pucky

macrumors newbie
Aug 12, 2006
3
0
what do you see when you type the following from a terminal?

diskutil list

<this is what I see>
MACBOOKPRO:~ pucky$ diskutil list
/dev/disk0
#: type name size identifier
0: GUID_partition_scheme *93.2 GB disk0
1: EFI 200.0 MB disk0s1
2: Apple_HFS osx 92.8 GB disk0s2
</this is what I see>

The reason I ask this is diskutil has a resizeVolume option.